]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils-sdk: Fix broken linker paths with correct sysroot option (and remove unused...
authorRichard Purdie <richard@openedhand.com>
Mon, 18 Jun 2007 19:45:29 +0000 (19:45 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 18 Jun 2007 19:45:29 +0000 (19:45 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1970 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/binutils/binutils-cross-sdk.inc [deleted file]
meta/packages/binutils/binutils-cross-sdk_2.17.50.0.5.bb

diff --git a/meta/packages/binutils/binutils-cross-sdk.inc b/meta/packages/binutils/binutils-cross-sdk.inc
deleted file mode 100644 (file)
index 6cc0579..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-inherit sdk
-DEPENDS += "flex-native bison-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
-EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
-               --program-prefix=${TARGET_PREFIX}"
-
-
-FILES_binutils-cross-sdk-dbg = ""
-do_install () {
-       autotools_do_install
-
-       # We don't really need these, so we'll remove them...
-       rm -rf ${D}${libdir}/ldscripts
-
-       # Fix the /usr/${TARGET_SYS}/bin/* links
-       for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
-               rm -f $l
-               ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
-                       | tr -s / \
-                       | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
-       done
-
-       # Install the libiberty header
-       install -d ${D}${includedir}
-       install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
-       install -m 644 ${S}/include/libiberty.h ${D}${includedir}
-
-       cd ${D}${bindir}
-
-       # Symlinks for ease of running these on the native target
-       for p in ${TARGET_SYS}-* ; do
-               ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
-       done
-}
index 7d3bb6c09c946a7a34344c4c6b17b9f7b101ec34..a045d9bc9c1e9cea19b3cc0b8921b57ee5f1d80e 100644 (file)
@@ -3,8 +3,9 @@ require binutils_${PV}.bb
 inherit sdk
 DEPENDS += "flex-native bison-native"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
-EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
+EXTRA_OECONF = "--with-sysroot=${prefix}/${TARGET_SYS} \
                --program-prefix=${TARGET_PREFIX}"
+PR = "r2"
 
 do_stage() {
        :