]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: add bzip2-replacement-native to DEPENDS to fix sstate issue
authorJan-Simon Moeller <dl9pf@gmx.de>
Thu, 21 May 2020 14:07:04 +0000 (16:07 +0200)
committerSteve Sakoman <steve@sakoman.com>
Sat, 23 May 2020 22:43:32 +0000 (12:43 -1000)
file-native when built on a Debian 10 host will embed a dependency to
'libbz2.so.1.0' (instead of 'libbz2.so.1'). This can cause issues
when sharing the sstate between hosts e.g.:

 recipe-sysroot-native/usr/lib/rpm/rpmdeps:
      error while loading shared libraries: libbz2.so.1.0: \
        cannot open shared object file: No such file or directory

To avoid this situation, let's add the bzip2-replacement-native to the
file recipe's DEPENDS_class-native .

Details in https://bugzilla.yoctoproject.org/show_bug.cgi?id=13915 .

Signed-off-by: Jan-Simon Moeller <dl9pf@gmx.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 4a996574464028bd5d57b90920d0887d1a81e9e9)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-devtools/file/file_5.38.bb

index f5ad568936f14fe07767601cbdbabb89661c9078..2d62ead10bb023b2848f457eca500e5d4d581bd4 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
 
 DEPENDS = "file-replacement-native"
-DEPENDS_class-native = ""
+DEPENDS_class-native = "bzip2-replacement-native"
 
 SRC_URI = "git://github.com/file/file.git"