]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools: copy also remove-potcdate.sin from ${STAGING_DATADIR_NATIVE}/gettext/po
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 12 Dec 2012 22:33:43 +0000 (23:33 +0100)
committerSaul Wold <sgw@linux.intel.com>
Fri, 14 Dec 2012 23:17:20 +0000 (15:17 -0800)
* some packages (e.g. uptime, cpu, forecasts, news from meta-efl)
  don't have remove-potcdate.sin in po subdirectory, but Makefile.in.in
  supplied by autotools.bbclass depends on it and fails without like this:
  | make[3]: Entering directory `/OE/shr-core/tmp-eglibc/work/x86_64-oe-linux/uptime/0.0.2+svnr80477-r0.0/E-MODULES-EXTRA/uptime/po'
  | make[3]: *** No rule to make target `remove-potcdate.sin', needed by `remove-potcdate.sed'.  Stop.
  | make[3]: Leaving directory `/OE/shr-core/tmp-eglibc/work/x86_64-oe-linux/uptime/0.0.2+svnr80477-r0.0/E-MODULES-EXTRA/uptime/po'
  | make[2]: *** [uptime.pot] Error 2

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/autotools.bbclass

index ca981ec47ad31cf0162e6e57157e788ef4c05678..9d1a2992c2db6f617f085b168d74c538f2c3689c 100644 (file)
@@ -193,6 +193,9 @@ autotools_do_configure() {
                                cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
                                if [ -d ${S}/po/ ]; then
                                        cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
+                                       if [ ! -e ${S}/po/remove-potcdate.sin ]; then
+                                               cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/
+                                       fi
                                fi
                                for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do
                                        for j in `find ${S} -name $i | grep -v aclocal-copy`; do