]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-firmware: package firmware for Marvell 88W8688
authorJens Rehsack <rehsack@gmail.com>
Wed, 16 Mar 2016 09:35:18 +0000 (10:35 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Mar 2016 21:50:12 +0000 (21:50 +0000)
According to error messages from guruplug

[   35.826441] btmrvl_sdio mmc0:0001:2: Direct firmware load for mrvl/sd8688_helper.bin failed with error -2
[   35.903291] Bluetooth: request_firmware(helper) failed, error code = -2
[   35.909942] Bluetooth: Failed to download helper!
[   36.052820] Bluetooth: Downloading firmware failed!
...
[  764.422739] libertas_sdio: Libertas SDIO driver
[  764.438213] libertas_sdio: Copyright Pierre Ossman
[  764.461186] libertas_sdio mmc0:0001:1: Direct firmware load for libertas/sd8688_helper.bin failed with error -2
[  764.488234] libertas_sdio mmc0:0001:1: Direct firmware load for sd8688_helper.bin failed with error -2
[  764.507382] libertas_sdio: failed to find firmware (-2)

and http://wiki.beyondlogic.org/index.php?title=GuruPlug_Libertas_SD8688,
package the firmware files for Marvell 88W8688, too.

Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/linux-firmware/linux-firmware_git.bb

index 979268670c20ac851415f48566ad9eb07fff8603..f4a3230f736f1d74956900ed5cdb785737ff5c00 100644 (file)
@@ -173,7 +173,7 @@ do_install() {
 
 PACKAGES =+ "${PN}-ralink-license ${PN}-ralink \
              ${PN}-radeon-license ${PN}-radeon \
-             ${PN}-marvell-license ${PN}-sd8686 ${PN}-sd8787 ${PN}-sd8797 \
+             ${PN}-marvell-license ${PN}-sd8686 ${PN}-sd8688 ${PN}-sd8787 ${PN}-sd8797 \
              ${PN}-ti-connectivity-license ${PN}-wl12xx ${PN}-wl18xx \
              ${PN}-vt6656-license ${PN}-vt6656 \
              ${PN}-rtl-license ${PN}-rtl8192cu ${PN}-rtl8192ce ${PN}-rtl8192su \
@@ -254,6 +254,7 @@ RDEPENDS_${PN}-radeon += "${PN}-radeon-license"
 
 # For marvell
 LICENSE_${PN}-sd8686 = "Firmware-Marvell"
+LICENSE_${PN}-sd8688 = "Firmware-Marvell"
 LICENSE_${PN}-sd8787 = "Firmware-Marvell"
 LICENSE_${PN}-sd8797 = "Firmware-Marvell"
 
@@ -262,6 +263,10 @@ FILES_${PN}-sd8686 = " \
   /lib/firmware/libertas/sd8686_v9* \
   /lib/firmware/sd8686* \
 "
+FILES_${PN}-sd8688 = " \
+  /lib/firmware/libertas/sd8688* \
+  /lib/firmware/mrvl/sd8688* \
+"
 FILES_${PN}-sd8787 = " \
   /lib/firmware/mrvl/sd8787_uapsta.bin \
 "
@@ -270,6 +275,7 @@ FILES_${PN}-sd8797 = " \
 "
 
 RDEPENDS_${PN}-sd8686 += "${PN}-marvell-license"
+RDEPENDS_${PN}-sd8688 += "${PN}-marvell-license"
 RDEPENDS_${PN}-sd8787 += "${PN}-marvell-license"
 RDEPENDS_${PN}-sd8797 += "${PN}-marvell-license"