]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.15: add build dependencies
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 19 Feb 2018 02:25:45 +0000 (21:25 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Feb 2018 16:06:27 +0000 (16:06 +0000)
Some required build dependencies were missed when the -rt variant
for linux-yocto was created. We add them here to match the 4.15
recipe. Eventually, these can be placed in a common location and
included automatically.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb

index 31f8c23cef52c745c7a1e8ef71944fdf34cd29f5..03726a46a40da2369cdda9a53fb37edcdcfd5e78 100644 (file)
@@ -19,6 +19,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=mac
 
 LINUX_VERSION ?= "4.15"
 
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "kernel-meta"