]> code.ossystems Code Review - openembedded-core.git/commitdiff
quota: Replace using -I= with STAGING_INCDIR
authorKhem Raj <raj.khem@gmail.com>
Sat, 12 Sep 2015 17:08:28 +0000 (17:08 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Sep 2015 14:39:37 +0000 (15:39 +0100)
-I= is gcc specific, using STAGING_INCDIR makes it compiler independent
Update posix types patch to include new u_int -> uint32_t changes

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/quota/quota/remove_non_posix_types.patch
meta/recipes-extended/quota/quota_4.02.bb

index 5442d9854d7beae7dca84498e675e04188fbbf76..06ff13cb981886c99edad61e26281a5adac17d36 100644 (file)
@@ -183,3 +183,16 @@ Index: quota-tools/quot.h
  } du_t;
  
  #define       NDU     60000
+Index: quota-tools/rquota_server.c
+===================================================================
+--- quota-tools.orig/rquota_server.c
++++ quota-tools/rquota_server.c
+@@ -60,7 +60,7 @@ extern char nfs_pseudoroot[PATH_MAX];
+  */
+ extern struct authunix_parms *unix_cred;
+-int in_group(gid_t * gids, u_int len, gid_t gid)
++int in_group(gid_t * gids, uint32_t len, gid_t gid)
+ {
+       gid_t *gidsp = gids + len;
index 124b0a36912736131a886ef0310d8ed17c027597..673d58428a49591405540eee4aca711c637ce264 100644 (file)
@@ -23,7 +23,7 @@ DEPENDS = "gettext-native e2fsprogs"
 
 inherit autotools-brokensep gettext pkgconfig
 
-CFLAGS += "-I=${includedir}/tirpc"
+CFLAGS += "-I${STAGING_INCDIR}/tirpc"
 LDFLAGS += "-ltirpc"
 ASNEEDED = ""
 EXTRA_OEMAKE += 'STRIP=""'