]> code.ossystems Code Review - openembedded-core.git/commitdiff
mpc8315e-rdb: create machine and tuning configuration
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 11 Oct 2010 04:26:12 +0000 (00:26 -0400)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 21:57:00 +0000 (22:57 +0100)
BUGID: 423

Introduce the basic mpc8315e BSP. By default this BSP uses
the basic 603 tuning and soft-float. There are issues with
the e300 tuning and eglibc, and the compiler. Subsequent
commits will further tune this BSP.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/conf/machine/include/tune-ppce300c2.inc [new file with mode: 0644]
meta/conf/machine/mpc8315e-rdb.conf [new file with mode: 0644]
meta/recipes-kernel/linux/linux-wrs_git.bb

index 5f36c7b5e72a9e40395518b4867ae30a21fff030..67bf4c419b95aa699828ef7c9771690550a626dd 100644 (file)
@@ -90,7 +90,8 @@ SRCREV_machine_pn-linux-wrs_qemux86-64 ?= "0431115c9d720fee5bb105f6a7411efb4f851
 SRCREV_machine_pn-linux-wrs_emenlow ?= "aae69fdf104b0a9d7b3710f808aac6ab303490f7"
 SRCREV_machine_pn-linux-wrs_atom-pc ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
 SRCREV_machine_pn-linux-wrs_routerstationpro ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
-SRCREV_meta_pn-linux-wrs ?= "bfef596973ae436db9132065eaab2228c98f938b"
+SRCREV_machine_pn-linux-wrs_mpc8315e-rdb ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
+SRCREV_meta_pn-linux-wrs ?= "134a33e3a43579114ca5263e34c18a5d6854d085"
 SRCREV_pn-linux-libc-headers-wrs ??= "09a39c638dd65dc27c549c119abe1af2631b2ae0"
 SRCREV_pn-matchbox-config-gtk ??= "2081"
 SRCREV_pn-matchbox-desktop-sato ??= "76"
diff --git a/meta/conf/machine/include/tune-ppce300c2.inc b/meta/conf/machine/include/tune-ppce300c2.inc
new file mode 100644 (file)
index 0000000..067a7b1
--- /dev/null
@@ -0,0 +1,2 @@
+TARGET_CC_ARCH = "-mcpu=e300c2 -msoft-float"
+BASE_PACKAGE_ARCH = "ppce300"
diff --git a/meta/conf/machine/mpc8315e-rdb.conf b/meta/conf/machine/mpc8315e-rdb.conf
new file mode 100644 (file)
index 0000000..a2aeea9
--- /dev/null
@@ -0,0 +1,16 @@
+#@TYPE: Machine
+#@DESCRIPTION: Machine configuration for running 
+
+TARGET_ARCH = "powerpc"
+PACKAGE_EXTRA_ARCHS = "ppce300"
+TARGET_FPU = "spe"
+
+require conf/machine/include/tune-ppc603e.inc
+
+KERNEL_IMAGETYPE = "uImage"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-wrs"
index f99be25c7528adc8a78b81b83f487308be4a7b54..00e74022ef95f85797dd23b046401bdb31cecc98 100644 (file)
@@ -27,12 +27,13 @@ WRMACHINE_qemumips = "mti_malta32_be"
 WRMACHINE_qemuarm  = "arm_versatile_926ejs"
 WRMACHINE_atom-pc  = "common_pc"
 WRMACHINE_routerstationpro = "routerstationpro"
+WRMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
 
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb)"
 
 LINUX_VERSION = "v2.6.34"
 LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
-PR = "r8"
+PR = "r9"
 
 S = "${WORKDIR}/linux"
 B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"