]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd-compat-units: do not mask available services
authorAnders Darander <anders@chargestorm.se>
Fri, 10 Jan 2014 07:15:03 +0000 (08:15 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jan 2014 11:33:16 +0000 (11:33 +0000)
Do also check systemd_unitdir/system/ for available unit files.

This was hiding dnsmasq.service for us, as /etc/systemd/system has
priority over systemd_unitdir/system...

Signed-off-by: Anders Darander <anders@chargestorm.se>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/systemd/systemd-compat-units.bb

index 9f282835708b10db33b2b91e57bbf0eb5333f54d..e32ad791ec74296aa7d9261e53b54cd738944963 100644 (file)
@@ -42,7 +42,7 @@ pkg_postinst_${PN} () {
        fi
 
        for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
-               if [ \( -e $i -o $i.sh \) -a ! -e $D${sysconfdir}/systemd/system/$i.service ] ; then
+               if [ \( -e $i -o $i.sh \) -a ! \( -e $D${sysconfdir}/systemd/system/$i.service -o  -e $D${systemd_unitdir}/system/$i.service \) ] ; then
                        echo -n "$i: " ; systemctl ${OPTS} mask $i.service
                fi
        done ; echo