]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: add mdmon service to support Intel VROC
authorLiwei Song <liwei.song@windriver.com>
Thu, 21 Mar 2019 03:19:09 +0000 (23:19 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 24 Mar 2019 17:00:54 +0000 (17:00 +0000)
Install mdmon@.service to make Intel VROC work well.

mdmon@.service called from udev is used to update Intel VROC metadata,
with it the VROC raid is operational to read or write under user space.

Signed-off-by: Liwei Song <liwei.song@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/mdadm/mdadm_4.1.bb

index d79c533f213aa8bf6e7be0747ee20368c5d1bd59..6b32f08abee1e1de2cb12ab7e4a567dee26d9095 100644 (file)
@@ -26,7 +26,7 @@ SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1
 
 inherit autotools-brokensep ptest systemd
 
-SYSTEMD_SERVICE_${PN} = "mdmonitor.service"
+SYSTEMD_SERVICE_${PN} = "mdmonitor.service mdmon@.service"
 SYSTEMD_AUTO_ENABLE = "disable"
 
 CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member"
@@ -57,6 +57,7 @@ do_install_append() {
         install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
         install -d ${D}/${systemd_unitdir}/system
         install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
+        install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
         install -d ${D}/${sysconfdir}/init.d
         install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
 }