]> code.ossystems Code Review - openembedded-core.git/commitdiff
fontconfig: Fix pkgconfig file generation to not have absolute paths
authorKhem Raj <raj.khem@gmail.com>
Fri, 24 Apr 2015 03:35:32 +0000 (20:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 27 Apr 2015 13:57:45 +0000 (14:57 +0100)
Fixes cross building dependent packages with gcc-5
e.g. matchbox-panel-2

Change-Id: I6290cfa4aac5d03a7200472d0c713b7ea84b99ac
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/fontconfig/fontconfig/revert-static-pkgconfig.patch [new file with mode: 0644]
meta/recipes-graphics/fontconfig/fontconfig_2.11.93.bb

diff --git a/meta/recipes-graphics/fontconfig/fontconfig/revert-static-pkgconfig.patch b/meta/recipes-graphics/fontconfig/fontconfig/revert-static-pkgconfig.patch
new file mode 100644 (file)
index 0000000..a2f3409
--- /dev/null
@@ -0,0 +1,20 @@
+Revert part of http://cgit.freedesktop.org/fontconfig/commit/fontconfig.pc.in?id=338ffe6b886ad4ba86ff471cb59c4a5e5ffbe408
+We really dont do static linking so its not going to cause issues for us but as such this is harming us by adding absolute
+paths into -I options into fontconfig.pc which is them prepended with sysroot when read back by cross pkg-config and
+we end up with -I <sysroot>/<sysroot>/usr/include/fontconfig in CFLAGS of clients which depend on it. one such example
+is matchbox-panel-2 and it was working fine with gcc < 5 because it tolerated non-existing paths in -I flags but gcc-5
+gently refuses and rightly so.
+
+Upstream-Status: Not-Submitted [OE-Specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: fontconfig-2.11.93/fontconfig.pc.in
+===================================================================
+--- fontconfig-2.11.93.orig/fontconfig.pc.in
++++ fontconfig-2.11.93/fontconfig.pc.in
+@@ -15,4 +15,4 @@ Requires: @PKGCONFIG_REQUIRES@
+ Requires.private: @PKGCONFIG_REQUIRES_PRIVATELY@
+ Libs: -L${libdir} -lfontconfig
+ Libs.private: @EXPAT_LIBS@ @FREETYPE_LIBS@ @ICONV_LIBS@ @LIBXML2_LIBS@
+-Cflags: -I${includedir} @EXPAT_CFLAGS@ @FREETYPE_CFLAGS@ @ICONV_CFLAGS@ @LIBXML2_CFLAGS@
++Cflags: -I${includedir}
index 44cfe2b2bfc4bf3e1138ce3c7ad0fd727cd86f63..e024adb5d988db57fc4ea34fc78027c3870da60d 100644 (file)
@@ -21,6 +21,7 @@ SECTION = "libs"
 DEPENDS = "expat freetype zlib"
 
 SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
+           file://revert-static-pkgconfig.patch \
            "
 SRC_URI[md5sum] = "622f94f0f74e40775ea72d7d5f17a36d"
 SRC_URI[sha256sum] = "296b5e83189589e537992d65ff01e0cd74eba9a91eb16a6890ce942e3695c526"