]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Updates to ensure Config-heavy-target.pl is found
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 18 Nov 2009 22:04:55 +0000 (22:04 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 18 Nov 2009 22:04:55 +0000 (22:04 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/perl/perl-5.8.8/perl-configpm-switch.patch
meta/packages/perl/perl_5.8.8.bb

index 1aacd35189b030dd426c6e4d0508c640c47a1b53..ac519a0271f2fbb3cfe55b9e0565801a4fbd9340 100644 (file)
@@ -18,7 +18,7 @@ values would be valid for the host only.
  
      return $self->fetch_string($key);
  }
-@@ -530,7 +530,12 @@
+@@ -530,7 +530,21 @@
  sub DESTROY { }
  
  sub AUTOLOAD {
@@ -28,7 +28,16 @@ values would be valid for the host only.
 +    {
 +        $cfgfile = 'Config_heavy-target.pl';
 +    }
-+    require $cfgfile;
++    if (defined $ENV{PERL_ARCHLIB})
++    {
++        push @INC, $ENV{PERL_ARCHLIB};
++        require $cfgfile;
++        pop @INC;
++    }
++    else
++    {
++        require $cfgfile;
++    }
      goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/;
      die "&Config::AUTOLOAD failed on $Config::AUTOLOAD";
  }
index fa1a8d34c9ccff523aa5f9a5ac276724bdd96b6f..bf68cfcc8e6dc8be0b5a8dd196cc9050ecfa45fe 100644 (file)
@@ -129,6 +129,8 @@ do_install() {
 
         install -d ${D}${datadir}/perl/${PV}/ExtUtils
        install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
+       
+       ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
 }
 
 PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"