]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-parser-perl: Fix debug package
authorMark Hatle <mark.hatle@windriver.com>
Mon, 20 Jun 2011 18:12:07 +0000 (13:12 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 10:59:46 +0000 (11:59 +0100)
Certain files were being missed in the -dbg package, fix this.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb

index fac28a83df5a3a8fca44afadefba0eb7e7e7b8cb..3c8f1c9ab9f7f4b47c518d1999b519c558bfa3e2 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "Artistic"
 LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e42d1cf8b51f1"
 DEPENDS += "expat expat-native"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
 
@@ -16,6 +16,8 @@ EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}
 
 inherit cpan
 
+FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/XML/Parser/Expat/.debug/"
+
 do_compile() {
        export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
        cpan_do_compile