]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconfig: Fix build with gcc-6
authorTim Orling <timothy.t.orling@linux.intel.com>
Fri, 15 Jul 2016 01:49:32 +0000 (18:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2016 07:32:53 +0000 (08:32 +0100)
Our patch in master was on top of 0.29.1 update.
commit b83a808fcbd3e7aec3b0757c7180cf83dac44e92

Apply to krogoth stable 0.29 version instead.

[YOCTO #9897] (Fedora-24)

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/pkgconfig/pkgconfig/0001-gdate-suppress-string-format-literal-warning.patch [new file with mode: 0644]
meta/recipes-devtools/pkgconfig/pkgconfig_git.bb

diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig/0001-gdate-suppress-string-format-literal-warning.patch b/meta/recipes-devtools/pkgconfig/pkgconfig/0001-gdate-suppress-string-format-literal-warning.patch
new file mode 100644 (file)
index 0000000..830d3d2
--- /dev/null
@@ -0,0 +1,34 @@
+The upstream patch would not apply cleanly, so perform the same changes.
+
+Original patch header:
+From 00148329967adb196138372771052a3f606a6ea3 Mon Sep 17 00:00:00 2001
+From: coypu <coypu@sdf.org>
+Date: Wed, 2 Mar 2016 19:43:10 +0200
+Subject: [PATCH 2/2] gdate: Suppress string format literal warning
+
+Newer versions of GCC emit an error here, but we know it's safe.
+https://bugzilla.gnome.org/761550
+
+Upstream-Status: Backport
+
+Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
+
+Index: git/glib/glib/gdate.c
+===================================================================
+--- git.orig/glib/glib/gdate.c
++++ git/glib/glib/gdate.c
+@@ -2439,6 +2439,8 @@ win32_strftime_helper (const GDate     *
+  *
+  * Returns: number of characters written to the buffer, or 0 the buffer was too small
+  */
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-nonliteral"
+ gsize     
+ g_date_strftime (gchar       *s, 
+                  gsize        slen, 
+@@ -2549,3 +2551,5 @@ g_date_strftime (gchar       *s,
+   return retval;
+ #endif
+ }
++
++#pragma GCC diagnostic pop
index d34f608f119d38a0271e7eef2cf72cbc03eb6deb..cd4dc8e7e8bbe994f3e0841d0a2e294d4e0fa3a0 100644 (file)
@@ -18,6 +18,7 @@ PV = "0.29+git${SRCPV}"
 SRC_URI = "git://anongit.freedesktop.org/pkg-config \
            file://pkg-config-native.in \
            file://fix-glib-configure-libtool-usage.patch \
+          file://0001-gdate-suppress-string-format-literal-warning.patch \
            "
 
 S = "${WORKDIR}/git"