]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer1.0-plugins-good: Decrease the rank as havn't this kind of decoder for aster...
authorZidan Wang <b50113@freescale.com>
Tue, 30 Dec 2014 02:55:52 +0000 (10:55 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Dec 2014 08:11:50 +0000 (08:11 +0000)
When streaming H263 stream on RTSP, asteriskh263 will be loaded, but it can't
find this kind of video decoder. So decrease the rank as havn't this kind of
decoder.

https://bugzilla.gnome.org/show_bug.cgi?id=739935

Signed-off-by: Zidan Wang <b50113@freescale.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/decrease_asteriskh263_rank.patch [new file with mode: 0755]
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.4.1.bb

diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/decrease_asteriskh263_rank.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/decrease_asteriskh263_rank.patch
new file mode 100755 (executable)
index 0000000..7f94f50
--- /dev/null
@@ -0,0 +1,25 @@
+commit d71d74daac8ed54156ed103958ab455c63c72b0e
+Author: Song Bing <b06498@freescale.com>
+Date:   Mon Nov 10 11:25:47 2014 +0800
+
+[asteriskh263] decrease the rank as we havn't this kind of decoder.
+
+Decrease the rank as we havn't this kind of decoder.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=739935
+
+Upstream Status: Pending
+
+Signed-off-by: Song Bing <b06498@freescale.com>
+
+diff --git a/gst/rtp/gstasteriskh263.c b/gst/rtp/gstasteriskh263.c
+index a01fbc8..8fa3194 100644
+--- a/gst/rtp/gstasteriskh263.c
++++ b/gst/rtp/gstasteriskh263.c
+@@ -226,5 +226,5 @@ gboolean
+ gst_asteriskh263_plugin_init (GstPlugin * plugin)
+ {
+   return gst_element_register (plugin, "asteriskh263",
+-      GST_RANK_SECONDARY, GST_TYPE_ASTERISK_H263);
++      GST_RANK_SECONDARY - 1, GST_TYPE_ASTERISK_H263);
+ }
index 441dd51e39def7a34a49f19bbf80c836208e35f3..05798cf494ea73fa013d534e0d37cb00e0127cba 100644 (file)
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
                     file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
 
 SRC_URI += "file://0001-gstrtpmp4gpay-set-dafault-value-for-MPEG4-without-co.patch \
+            file://decrease_asteriskh263_rank.patch \
 "
 SRC_URI[md5sum] = "eb3a3296b2f6009def1f5a09590ce767"
 SRC_URI[sha256sum] = "8559d4270065b30ed5c49b826e1b7a3a2bd5ee9a340ae745a2ae3f9718e4c637"