]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi: Remove startup warning if dbus isn't setup yet
authorRichard Purdie <richard@openedhand.com>
Fri, 28 Jul 2006 16:53:13 +0000 (16:53 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 28 Jul 2006 16:53:13 +0000 (16:53 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@581 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/avahi/avahi_0.6.10.bb

index 2b12d91c8df492c46b85e737cf5d66d83680037a..2a6eb24033edd6700f809a41c6727c6ce6d33591 100644 (file)
@@ -5,6 +5,7 @@ AUTHOR = "Lennart Poettering <lennart@poettering.net>"
 HOMEPAGE = "http://avahi.org"
 MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
 LICENSE= "GPL"
+PR = "r1"
 
 DEPENDS = "expat libdaemon dbus"
 RRECOMMENDS = "libnss-mdns"
@@ -49,9 +50,16 @@ pkg_postinst_avahi-daemon () {
 
        grep avahi /etc/group || addgroup avahi
        grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
-       /etc/init.d/dbus-1 force-reload
+
+       DBUSPID=`pidof dbus-daemon`
+
+       if [ "x$DBUSPID" != "x" ]; then
+               /etc/init.d/dbus-1 force-reload
+       fi
 }
 
+# dbus errors to /dev/null as at the time the postinst runs, dbus might not be setup.
+
 pkg_postrm_avahi-daemon () {
        deluser avahi || true
        delgroup avahi || true