]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: create intel branches
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 27 May 2016 14:32:21 +0000 (10:32 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 May 2016 14:56:48 +0000 (15:56 +0100)
To provide timely support for Intel platforms, without risking
issues with other platforms, we create intel branches from the
common variants.

i.e. We now have standard/intel, which is from standard/base

These branches will be managed like any other in the tree, and
will get common -stable, -rt, bugs and CVE updates.

Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
meta/recipes-kernel/linux/linux-yocto_4.1.bb
meta/recipes-kernel/linux/linux-yocto_4.4.bb

index 51fa3adeb2097e1eb1e7d9334e347ec71225517c..dcdc74578311e0a3d26d4bf90f4d00e07086d1b0 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "320892013ad33ab41f530ad321939aec07d09d22"
-SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
+SRCREV_meta ?= "2b07d06557a049b6ef7038a31651279c33794dbd"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
index a6f7dcca5ec4e483c2a5cefadbba63e0b0ad9be8..15740f9b8ea96389ab38f12b763aba7011176979 100644 (file)
@@ -1,4 +1,4 @@
-KBRANCH ?= "standard/preempt-rt"
+KBRANCH ?= "standard/preempt-rt/base"
 
 require recipes-kernel/linux/linux-yocto.inc
 
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "3bdc347cc2087a0217e3acddccda5bb775cd570b"
-SRCREV_meta ?= "6ec93aaa70f838b551f58b91d0c6ffeff6f6094b"
+SRCREV_meta ?= "1465ac389f22979618852aa04298049cfdd5dcb4"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
index 35a76ef0cd07d5a5dc0a9bae2e9a815d491fa19b..ce69c55fd5979bfcec003bf3c2c9df63286269c5 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
+SRCREV_meta ?= "2b07d06557a049b6ef7038a31651279c33794dbd"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index e05b27a769d4779c0cc442241de66223450ef8fb..30a9ecb7c0965ac01412e01fd4070f487cc90bef 100644 (file)
@@ -10,7 +10,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "53e84104c5e68eb468823dd0d262a64623d01a55"
-SRCREV_meta ?= "6ec93aaa70f838b551f58b91d0c6ffeff6f6094b"
+SRCREV_meta ?= "1465ac389f22979618852aa04298049cfdd5dcb4"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 2332e11f42edf9bf684cf380d0daa39ea14ea40b..39fab5f4a4f17fcbb7758b2024de7c886d3d9953 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "ecc983477682203619da0e456fa4a8689ac41097"
 SRCREV_machine_qemux86-64 ?= "ecc983477682203619da0e456fa4a8689ac41097"
 SRCREV_machine_qemumips64 ?= "1db47ec6c39071b29f82a040b9b9a81584f50461"
 SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
+SRCREV_meta ?= "2b07d06557a049b6ef7038a31651279c33794dbd"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
index 984a49c85e51d925eeb59aec5f978c1a6ce2e3b1..117fe5bc2c46da75dbe2c6ccd2bbdbb4371723cb 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "53e84104c5e68eb468823dd0d262a64623d01a55"
 SRCREV_machine_qemux86-64 ?= "53e84104c5e68eb468823dd0d262a64623d01a55"
 SRCREV_machine_qemumips64 ?= "7ce6e58742b2f1f79cc8b1a1fff8bc408a3b585e"
 SRCREV_machine ?= "53e84104c5e68eb468823dd0d262a64623d01a55"
-SRCREV_meta ?= "6ec93aaa70f838b551f58b91d0c6ffeff6f6094b"
+SRCREV_meta ?= "1465ac389f22979618852aa04298049cfdd5dcb4"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"