]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: fix CVE-2014-0195
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 9 Jun 2014 15:51:16 +0000 (16:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Jun 2014 16:10:34 +0000 (17:10 +0100)
From the OpenSSL Security Advisory [05 Jun 2014]
http://www.openssl.org/news/secadv_20140605.txt

DTLS invalid fragment vulnerability (CVE-2014-0195)

A buffer overrun attack can be triggered by sending invalid DTLS fragments
to an OpenSSL DTLS client or server. This is potentially exploitable to
run arbitrary code on a vulnerable client or server.

Only applications using OpenSSL as a DTLS client or server affected.

(Patch borrowed from Fedora.)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/openssl/openssl/openssl-1.0.1e-cve-2014-0195.patch [new file with mode: 0644]
meta/recipes-connectivity/openssl/openssl_1.0.1g.bb

diff --git a/meta/recipes-connectivity/openssl/openssl/openssl-1.0.1e-cve-2014-0195.patch b/meta/recipes-connectivity/openssl/openssl/openssl-1.0.1e-cve-2014-0195.patch
new file mode 100644 (file)
index 0000000..0c43919
--- /dev/null
@@ -0,0 +1,40 @@
+commit 208d54db20d58c9a5e45e856a0650caadd7d9612
+Author: Dr. Stephen Henson <steve@openssl.org>
+Date:   Tue May 13 18:48:31 2014 +0100
+
+    Fix for CVE-2014-0195
+    
+    A buffer overrun attack can be triggered by sending invalid DTLS fragments
+    to an OpenSSL DTLS client or server. This is potentially exploitable to
+    run arbitrary code on a vulnerable client or server.
+    
+    Fixed by adding consistency check for DTLS fragments.
+    
+    Thanks to Jüri Aedla for reporting this issue.
+
+Patch borrowed from Fedora
+Upstream-Status: Backport
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/ssl/d1_both.c b/ssl/d1_both.c
+index 2e8cf68..07f67f8 100644
+--- a/ssl/d1_both.c
++++ b/ssl/d1_both.c
+@@ -627,7 +627,16 @@ dtls1_reassemble_fragment(SSL *s, struct hm_header_st* msg_hdr, int *ok)
+               frag->msg_header.frag_off = 0;
+               }
+       else
++              {
+               frag = (hm_fragment*) item->data;
++              if (frag->msg_header.msg_len != msg_hdr->msg_len)
++                      {
++                      item = NULL;
++                      frag = NULL;
++                      goto err;
++                      }
++              }
++
+       /* If message is already reassembled, this must be a
+        * retransmit and can be dropped.
+
index 579cf0376ec1fe0afb2a32f98f9a73efed8082a4..d4fc91d85101d9be2bdf0c6f73fcaf4dc9b41f84 100644 (file)
@@ -35,6 +35,7 @@ SRC_URI += "file://configure-targets.patch \
             file://find.pl \
             file://openssl-fix-des.pod-error.patch \
             file://openssl-CVE-2014-0198-fix.patch \
+            file://openssl-1.0.1e-cve-2014-0195.patch \
             file://openssl-CVE-2010-5298.patch \
            "