]> code.ossystems Code Review - openembedded-core.git/commitdiff
libbsd: libbsd-overlay.pc: Set Cflags to use -I instead of -isystem
authorFabio Berton <fabio.berton@ossystems.com.br>
Mon, 30 Jan 2017 16:27:00 +0000 (14:27 -0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 5 Feb 2017 09:20:19 +0000 (09:20 +0000)
pkg-config currently only handles -I and -L correctly, but misses
-isystem, so we need to do this workaround to fix this issue.

There's a open bug in:
https://bugzilla.freedesktop.org/show_bug.cgi?id=99516

This appears when building lldpd and shows error:

ERROR: lldpd-0.9.6-r0 do_configure: This autoconf log indicates
errors, it looked at host include and/or library paths while
determining system capabilities.
Rerun configure task after fixing this.
ERROR: lldpd-0.9.6-r0 do_configure: Function failed: do_qa_configure

Change-Id: I83255b5952e19bb2f516b1186276cd03eb67eed3
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/libbsd/libbsd/0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch [new file with mode: 0644]
meta/recipes-support/libbsd/libbsd_0.8.3.bb

diff --git a/meta/recipes-support/libbsd/libbsd/0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch b/meta/recipes-support/libbsd/libbsd/0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch
new file mode 100644 (file)
index 0000000..7e3a5b3
--- /dev/null
@@ -0,0 +1,33 @@
+From b6972f1c29ebf073cbe19a4a669ee093259792a0 Mon Sep 17 00:00:00 2001
+From: Fabio Berton <fabio.berton@ossystems.com.br>
+Date: Mon, 30 Jan 2017 12:00:33 -0200
+Subject: [PATCH] src/libbsd-overlay.pc.in: Set Cflags to use -I instead of
+ -isystem
+Organization: O.S. Systems Software LTDA.
+
+pkg-config currently only handles -I and -L correctly, but misses
+-isystem, so we need to do this workaround to fix this issue.
+
+There's a open bug in:
+https://bugzilla.freedesktop.org/show_bug.cgi?id=99516
+
+Upstream-Status: Pending
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ src/libbsd-overlay.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libbsd-overlay.pc.in b/src/libbsd-overlay.pc.in
+index ac8bf89..65dc3ae 100644
+--- a/src/libbsd-overlay.pc.in
++++ b/src/libbsd-overlay.pc.in
+@@ -8,4 +8,4 @@ Description: Utility functions from BSD systems (overlay)
+ Version: @VERSION@
+ URL: https://libbsd.freedesktop.org/
+ Libs: -L${libdir} -lbsd
+-Cflags: -isystem ${includedir}/bsd -DLIBBSD_OVERLAY
++Cflags: -I${includedir}/bsd -DLIBBSD_OVERLAY
+-- 
+2.11.0
+
index fadd7886a2f05134c089a67ca88ab8e0d2898b80..e85ee2153d48df5636b0047c12c27d34465b8150 100644 (file)
@@ -35,6 +35,7 @@ SECTION = "libs"
 
 SRC_URI = " \
     http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+    file://0001-src-libbsd-overlay.pc.in-Set-Cflags-to-use-I-instead.patch \
 "
 SRC_URI_append_libc-musl  = " \
     file://0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch \