]> code.ossystems Code Review - openembedded-core.git/commitdiff
libzypp: fix mishandling of hyphenated arches
authorTom Zanussi <tom.zanussi@intel.com>
Wed, 2 Nov 2011 03:47:53 +0000 (22:47 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Nov 2011 21:44:23 +0000 (21:44 +0000)
Several hyphen-to-underscore translations were missing, causing
compiler errors trying to build arches with hyphens in their names.
This adds the missing translations.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
meta/recipes-extended/libzypp/libzypp_git.bb

index 20e8f7c33a39b2e4cc44acd3ca3fd3e501457fab..a6b270c50a5df22194def88c316447f4766368f0 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS  = "rpm boost curl libxml2 zlib sat-solver expat openssl udev"
 S = "${WORKDIR}/git"
 SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
 PV = "0.0-git${SRCPV}"
-PR = "r15"
+PR = "r16"
 
 SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
            file://no-doc.patch \
@@ -98,10 +98,10 @@ do_archgen () {
                esac
                if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then
                  echo -n "  const Arch Arch_${each_arch} " | tr - _            >> zypp/oe-arch.h
-                 echo "(_${each_arch});"                                       >> zypp/oe-arch.h
+                 echo "(_${each_arch});" | tr - _                              >> zypp/oe-arch.h
                else
                  echo -n "  const Arch Arch_${each_arch} " | tr - _            >> zypp/oe-arch.h
-                 echo "( IdString ( \"${each_arch}\" ) );"                     >> zypp/oe-arch.h
+                 echo "( IdString ( \"${each_arch}\" ) );" | tr - _            >> zypp/oe-arch.h
                fi
        done
        echo "#endif /* OE_PROTO */"                                            >> zypp/oe-arch.h
@@ -142,7 +142,7 @@ do_archgen () {
                COMPAT_WITH="${CARCH},${COMPAT} $COMPAT_WITH"
        done
        for each_compat in ${COMPAT_WITH} ; do
-               echo "        defCompatibleWith( ${each_compat} );"             >> zypp/oe-arch.h
+               echo "        defCompatibleWith( ${each_compat} );" | tr - _    >> zypp/oe-arch.h
        done
        echo "#endif /* DEF_COMPAT */"                                          >> zypp/oe-arch.h
        echo ""                                                                 >> zypp/oe-arch.h