]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add powertop recipe, and add to profiling task
authorRoss Burton <ross@openedhand.com>
Mon, 21 Jan 2008 16:56:08 +0000 (16:56 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 21 Jan 2008 16:56:08 +0000 (16:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3564 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/powertop/powertop_1.9.bb [new file with mode: 0644]
meta/packages/tasks/task-poky.bb

diff --git a/meta/packages/powertop/powertop_1.9.bb b/meta/packages/powertop/powertop_1.9.bb
new file mode 100644 (file)
index 0000000..ab84161
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
+
+CFLAGS += "${LDFLAGS}"
+
+do_configure() {
+    # We do not build ncurses with wide char support
+    sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
+do_install() {
+    oe_runmake install DESTDIR=${D}
+}
index f001f577e23fee90d3aab73eea0d150cf47f0f76..e208b79a7771bb71b9b65cb9ebb05c3b88be7e4b 100644 (file)
@@ -3,7 +3,7 @@
 #
 
 DESCRIPTION = "Tasks for OpenedHand Poky"
-PR = "r15"
+PR = "r16"
 
 PACKAGES = "\
     task-poky-apps-console \
@@ -115,6 +115,7 @@ RDEPENDS_task-poky-tools-profile = "\
     exmap-server \
     oprofile \
     oprofileui-server \
+    powertop \
     lttng-control \
     lttng-viewer"