]> code.ossystems Code Review - openembedded-core.git/commitdiff
fakeroot: Remove leagacy staging function and improve installed -dev package
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 20:17:00 +0000 (20:17 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 20:17:00 +0000 (20:17 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/fakeroot/fakeroot_1.9.4.bb

index 669fa5a38f1d22e2049babe37abe7d2f0a15294d..f2c3b01c859fc3abefe8a99157b836f2959d9af7 100644 (file)
@@ -12,9 +12,9 @@ SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
            
 inherit autotools_stage
 
-do_stage_append() {
-        install -d ${STAGING_INCDIR}/fakeroot
-        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+do_install_append() {
+       install -d ${D}${STAGING_INCDIR}/fakeroot/
+       install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot
 }
 
 # Compatability for the rare systems not using or having SYSV