]> code.ossystems Code Review - openembedded-core.git/commitdiff
pointercal: Always create a package but empty on devices without a default
authorRichard Purdie <richard@openedhand.com>
Thu, 17 May 2007 14:27:18 +0000 (14:27 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 17 May 2007 14:27:18 +0000 (14:27 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1751 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pointercal/files/pointercal [new file with mode: 0644]
meta/packages/pointercal/pointercal_0.0.bb

diff --git a/meta/packages/pointercal/files/pointercal b/meta/packages/pointercal/files/pointercal
new file mode 100644 (file)
index 0000000..e69de29
index 36bcca85bfe12bdae13d7aca45b8ad88abdc6b0a..6cf50241a683c2ede51fe31a484fc5baf715c5c7 100644 (file)
@@ -1,14 +1,17 @@
 DESCRIPTION = "Touchscreen calibration data"
 SECTION = "base"
-
-COMPATIBLE_MACHINE = "(spitz|c7x0|nokia800|akita)"
+PR = "r1"
 
 SRC_URI = "file://pointercal"
 S = "${WORKDIR}"
 
+ALLOW_EMPTY_${PN} = "1"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 do_install() {
-        install -d ${D}${sysconfdir}/
-        install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+       # Only install file if it has a contents
+       if [ -s ${S}/pointercal ]; then
+               install -d ${D}${sysconfdir}/
+               install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+       fi
 }