]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta: Rename LICENSE_FLAGS variable
authorSaul Wold <Saul.Wold@windriver.com>
Mon, 21 Feb 2022 18:36:13 +0000 (10:36 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Feb 2022 23:35:57 +0000 (23:35 +0000)
Signed-off-by: Saul Wold <saul.wold@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/base.bbclass
meta/classes/license.bbclass
meta/conf/bitbake.conf
meta/lib/oeqa/selftest/cases/distrodata.py
meta/lib/oeqa/selftest/cases/reproducible.py
meta/recipes-multimedia/gstreamer/gst-examples_1.18.6.bb
scripts/contrib/convert-variable-renames.py

index 87a4cb5fc778097f8888e7e8f80e825223630c0c..be820ddb2c24792be5205ec1d7040d801139d9c8 100644 (file)
@@ -542,9 +542,9 @@ python () {
         unmatched_license_flags = check_license_flags(d)
         if unmatched_license_flags:
             if len(unmatched_license_flags) == 1:
-                message = "because it has a restricted license '{0}'. Which is not whitelisted in LICENSE_FLAGS_WHITELIST".format(unmatched_license_flags[0])
+                message = "because it has a restricted license '{0}'. Which is not whitelisted in LICENSE_FLAGS_ACCEPTED".format(unmatched_license_flags[0])
             else:
-                message = "because it has restricted licenses {0}. Which are not whitelisted in LICENSE_FLAGS_WHITELIST".format(
+                message = "because it has restricted licenses {0}. Which are not whitelisted in LICENSE_FLAGS_ACCEPTED".format(
                     ", ".join("'{0}'".format(f) for f in unmatched_license_flags))
             bb.debug(1, "Skipping %s %s" % (pn, message))
             raise bb.parse.SkipRecipe(message)
index d5480d87e24b173952eb850b8a20b245285216fb..dd1e07ee377a7bfb88950f74d498bfea8ebdc0a7 100644 (file)
@@ -392,7 +392,7 @@ def check_license_flags(d):
 
     license_flags = d.getVar('LICENSE_FLAGS')
     if license_flags:
-        whitelist = d.getVar('LICENSE_FLAGS_WHITELIST')
+        whitelist = d.getVar('LICENSE_FLAGS_ACCEPTED')
         if not whitelist:
             return license_flags.split()
         unmatched_flags = all_license_flags_match(license_flags, whitelist)
index 3af649ce59459e0e778cf0ffd2d600ac0f1ae613..6fb7bfeb23c2c5441d919fbd7551cbc06b014808 100644 (file)
@@ -108,6 +108,7 @@ BB_RENAMED_VARIABLES[ICECC_USER_PACKAGE_BL] = "ICECC_RECIPE_DISABLE"
 BB_RENAMED_VARIABLES[ICECC_SYSTEM_PACKAGE_BL] = "ICECC_RECIPE_DISABLE"
 BB_RENAMED_VARIABLES[INHERIT_BLACKLIST] = "is a deprecated variable and no longer needed"
 BB_RENAMED_VARIABLES[TUNEABI_WHITELIST] = "is a deprecated variable and support has been removed"
+BB_RENAMED_VARIABLES[LICENSE_FLAGS_WHITELIST] = "LICENSE_FLAGS_ACCEPTED"
 
 ##################################################################
 # Architecture-dependent build variables.
index 908979804ab3ad8867b64b5968ac6576d2d0e352..03f31e9fcbfbc2c8b04ccc6e697110af12569347 100644 (file)
@@ -18,7 +18,7 @@ class Distrodata(OESelftestTestCase):
         Product:     oe-core
         Author:      Alexander Kanavin <alex.kanavin@gmail.com>
         """
-        feature = 'LICENSE_FLAGS_WHITELIST += " commercial"\n'
+        feature = 'LICENSE_FLAGS_ACCEPTED += " commercial"\n'
         self.write_config(feature)
 
         pkgs = oe.recipeutils.get_recipe_upgrade_status()
@@ -99,7 +99,7 @@ The following recipes do not have a DESCRIPTION. Please add an entry for DESCRIP
                      return True
             return False
 
-        feature = 'require conf/distro/include/maintainers.inc\nLICENSE_FLAGS_WHITELIST += " commercial"\nPARSE_ALL_RECIPES = "1"\nPACKAGE_CLASSES = "package_ipk package_deb package_rpm"\n'
+        feature = 'require conf/distro/include/maintainers.inc\nLICENSE_FLAGS_ACCEPTED += " commercial"\nPARSE_ALL_RECIPES = "1"\nPACKAGE_CLASSES = "package_ipk package_deb package_rpm"\n'
         self.write_config(feature)
 
         with bb.tinfoil.Tinfoil() as tinfoil:
index e539365031d62e7bcc930e9e749b7546d311b059..7caf8c3e7d5e7047fdfbecd3076c000b223ebbf4 100644 (file)
@@ -206,7 +206,7 @@ class ReproducibleTests(OESelftestTestCase):
             PACKAGE_CLASSES = "{package_classes}"
             INHIBIT_PACKAGE_STRIP = "1"
             TMPDIR = "{tmpdir}"
-            LICENSE_FLAGS_WHITELIST = "commercial"
+            LICENSE_FLAGS_ACCEPTED = "commercial"
             DISTRO_FEATURES:append = ' systemd pam'
             USERADDEXTENSION = "useradd-staticids"
             USERADD_ERROR_DYNAMIC = "skip"
index 8b4e3394360ce0ca646f95982b323ac1fc638636..02282ac5d9a48b4bfc4728cdf7860b9acbc89990 100644 (file)
@@ -30,6 +30,6 @@ RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback"
 RRECOMMENDS:${PN} = "gstreamer1.0-plugins-base-meta \
                      gstreamer1.0-plugins-good-meta \
                      gstreamer1.0-plugins-bad-meta \
-                      ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
-                     ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
+                      ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-libav", "", d)} \
+                     ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
 RPROVIDES:${PN} += "gst-player gst-player-bin"
index bc3e01887c506039a61ba118033f1edc32923f70..fca59ca9e1fbffd2524bdf297d8f6ee47a501027 100755 (executable)
@@ -42,6 +42,7 @@ renames = {
 "ICECC_USER_PACKAGE_WL" : "ICECC_RECIPE_ENABLE",
 "ICECC_USER_PACKAGE_BL" : "ICECC_RECIPE_DISABLE",
 "ICECC_SYSTEM_PACKAGE_BL" : "ICECC_RECIPE_DISABLE",
+"LICENSE_FLAGS_WHITELIST" : "LICENSE_FLAGS_ACCEPTED",
 }
 
 removed_list = [