]> code.ossystems Code Review - openembedded-core.git/commitdiff
archiver.bbclass: add bbappend when do_ar_recipe kernel and gcc packages
authorJian Liu <jian.liu@windriver.com>
Fri, 13 Nov 2015 08:21:46 +0000 (16:21 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Nov 2015 15:49:13 +0000 (15:49 +0000)
bbappend files are not included in the archiver during do_ar_recipe.
Find and put them into the tarball.

Signed-off-by: Jian Liu <jian.liu@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/archiver.bbclass

index d7a159dcd19a1cd000506ea31529bf6add14be58..328e2ed11a2a52581a0c9e735da0ab376ddb2c47 100644 (file)
@@ -298,6 +298,16 @@ python do_ar_recipe () {
     bb.utils.mkdirhier(outdir)
     shutil.copy(bbfile, outdir)
 
+    pn = d.getVar('PN', True)
+    bbappend_files = d.getVar('BBINCLUDED', True).split()
+    # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
+    # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
+    bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" %pn)
+    bbappend_re1 = re.compile( r".*/%s\.bbappend$" %pn)
+    for file in bbappend_files:
+        if bbappend_re.match(file) or bbappend_re1.match(file):
+            shutil.copy(file, outdir)
+
     dirname = os.path.dirname(bbfile)
     bbpath = '%s:%s' % (dirname, d.getVar('BBPATH', True))
     f = open(bbfile, 'r')