]> code.ossystems Code Review - openembedded-core.git/commitdiff
package.bbclass: Drop python depends from rpmdeps
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 11 Mar 2012 18:26:15 +0000 (18:26 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 11 Mar 2012 18:26:21 +0000 (18:26 +0000)
This python depends is added by rpmdeps every time it finds a python
script. This is not necessary since we handle this in otherways. It
also breaks things like nativesdk since the dependency is not renamed.
The easiest solution is just to ignore this dependency.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/package.bbclass
meta/recipes-devtools/python/python_2.7.2.bb

index e8c449711f3c67404becd9e136f362203dadbe97..9b6862decf13548236ef017c4b4d17dfc97a0ffc 100644 (file)
@@ -1185,6 +1185,8 @@ python package_do_filedeps() {
 
                        if value.startswith("rpmlib("):
                                continue
+                       if value == "python":
+                               continue
                        if file not in i:
                                i[file] = []
                        i[file].append(value)
index 2b18c5305cb8fecc295aad2f6a63e99560636c87..eb3965e21ab03d275c0b99b963ee5ee07e60b78f 100644 (file)
@@ -1,7 +1,7 @@
 require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
 
 DISTRO_SRC_URI ?= "file://sitecustomize.py"
 DISTRO_SRC_URI_linuxstdbase = ""