]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkitgtk: Add upstream patch to fix build problem
authorPushpal Sidhu <psidhu@gateworks.com>
Fri, 23 Oct 2015 21:03:21 +0000 (14:03 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Nov 2015 11:19:54 +0000 (11:19 +0000)
From Upstream webkit: fd15a368fa73fe08d91cc1dd7ef05c0c5a3ae851

Webkit will fail to compile under certain circumstances. Please see
https://bugs.webkit.org/show_bug.cgi?id=149172 for more details.

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch [new file with mode: 0644]
meta/recipes-sato/webkit/webkitgtk_2.8.5.bb

diff --git a/meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch b/meta/recipes-sato/webkit/files/0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch
new file mode 100644 (file)
index 0000000..e95c0e4
--- /dev/null
@@ -0,0 +1,35 @@
+From 6ea42d4fa6f3f6dd18c37cb7b6e1faea6afefba4 Mon Sep 17 00:00:00 2001
+From: "clopez@igalia.com" <clopez@igalia.com>
+Date: Tue, 15 Sep 2015 21:50:18 +0000
+Subject: [PATCH] [GTK] Build failure with ACCELERATED_2D_CANVAS when cairo-gl has
+ built with OpenGLESv2 support only.
+
+When cairo-gl is built with GLX and ACCELERATED_2D_CANVAS if cairo-gl was only
+built with OpenGLESv2, cairo-glx is not enabled causing
+Source/WebCore/platform/graphics/glx/GLContextGLX.cpp to reference an undeclared
+function and cause a compliation error. Adding an extra check resolves this
+build failure.
+
+Upstream-Status: Backport [webkit-2.10.0]
+
+Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
+---
+ Source/WebCore/platform/graphics/glx/GLContextGLX.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp b/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
+index 7890d8d..4ed3a43 100644
+--- a/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
++++ b/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp
+@@ -266,7 +266,7 @@ cairo_device_t* GLContextGLX::cairoDevice()
+     if (m_cairoDevice)
+         return m_cairoDevice;
+-#if ENABLE(ACCELERATED_2D_CANVAS)
++#if ENABLE(ACCELERATED_2D_CANVAS) && CAIRO_HAS_GLX_FUNCTIONS
+     m_cairoDevice = cairo_glx_device_create(sharedX11Display(), m_context);
+ #endif
+-- 
+2.6.2
+
index e29666ae78d78750d4ad649578353b35b763b65d..68634a9bc1fb7bbfbeedcdae5074dac679302d32 100644 (file)
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d842
 SRC_URI = "\
   http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
   file://0001-This-patch-fixes-a-command-line-that-is-too-long-ove.patch \
+  file://0002-GTK-Build-failure-with-ACCELERATED_2D_CANVAS-when-ca.patch \
   file://gcc5.patch \
   "
 SRC_URI[md5sum] = "df79991848a5096d3a75289ebce547ae"