]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: fix up misleading dir grouping names for lsb dirs
authorPaul Gortmaker <paul.gortmaker@windriver.com>
Mon, 28 Jul 2014 02:58:36 +0000 (22:58 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Jul 2014 08:56:30 +0000 (09:56 +0100)
In commit b0df35f47fb79dc149504bd66d1186b3276f9510
("base-files: Add to make some directories needed by LSB.") there
were new groupings of dirs made.  But rather than keep the grouping
names permissions based as they clearly were, it seems that it was
unfortunately misinterpreted as a counter, simply incrementing as
a new group was added.

This leads to dir3755 getting chmod'd to 0755 and dir4775 being
chmod'd to 2775 which to any new reader of the code is terribly
confusing.

Choose names that clearly reflect the permissions, and add a lsb
suffix to indicate the role.

Also note that the settings for /var/mail seem incorrect, and so
they have been aligned with what is seen in most common distros.

Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/files/fs-perms.txt
meta/recipes-core/base-files/base-files_3.0.14.bb

index 9c144109eaf1b9d7e9bf15599c9033c8c89d7991..109cbe553c1641c956ba106c7abcadc4e0d1598c 100644 (file)
@@ -60,8 +60,8 @@ ${localstatedir}/local                0755    root    root    false - - -
 /tmp                           01777   root    root    false - - -
 ${localstatedir}/volatile/tmp  01777   root    root    false - - -
 
-# Set 3755
+# Set 755-lsb
 /srv                           0755    root    root    false - - -
 
-# Set 4775
-/var/mail                      02755   root    root    false - - -
+# Set 2775-lsb
+/var/mail                      02775   root    mail    false - - -
index 10d0f449fa3fcd230dac39a7d5089c6d017f9730..30b1bf463b08709302ae8a0e8d4b34148420025e 100644 (file)
@@ -45,12 +45,13 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
            ${localstatedir}/volatile/log \
            /home ${prefix}/src ${localstatedir}/local \
            /media"
-dirs3755 = "/srv  \
-            ${prefix}/local ${prefix}/local/bin ${prefix}/local/games \
-            ${prefix}/local/include ${prefix}/local/lib ${prefix}/local/sbin \
-            ${prefix}/local/share ${prefix}/local/src \
-            ${prefix}/lib/locale"
-dirs4775 = "/var/mail"
+
+dirs755-lsb = "/srv  \
+               ${prefix}/local ${prefix}/local/bin ${prefix}/local/games \
+               ${prefix}/local/include ${prefix}/local/lib ${prefix}/local/sbin \
+               ${prefix}/local/share ${prefix}/local/src \
+               ${prefix}/lib/locale"
+dirs2775-lsb = "/var/mail"
 
 volatiles = "log tmp"
 conffiles = "${sysconfdir}/debian_version ${sysconfdir}/host.conf \
@@ -130,12 +131,12 @@ do_install_basefilesissue () {
 }
 
 do_install_append_linuxstdbase() {
-       for d in ${dirs3755}; do
+       for d in ${dirs755-lsb}; do
                 install -m 0755 -d ${D}$d
         done
 
-       for d in ${dirs4775}; do
-                install -m 2755 -d ${D}$d
+       for d in ${dirs2775-lsb}; do
+                install -m 2775 -d ${D}$d
         done
 }