]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: fix the num passed to memset in ar.c
authorZhenhua Luo <zhenhua.luo@freescale.com>
Fri, 15 Mar 2013 13:27:27 +0000 (21:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 16 Mar 2013 17:15:56 +0000 (17:15 +0000)
Following build error will appear on Fedora18+:
ar.c: In function 'do_oper_delete':
ar.c:918:31: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
   memset (found, '\0', sizeof (found));

Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils/elfutils-ar-c-fix-num-passed-to-memset.patch [new file with mode: 0644]
meta/recipes-devtools/elfutils/elfutils_0.148.bb

diff --git a/meta/recipes-devtools/elfutils/elfutils/elfutils-ar-c-fix-num-passed-to-memset.patch b/meta/recipes-devtools/elfutils/elfutils/elfutils-ar-c-fix-num-passed-to-memset.patch
new file mode 100644 (file)
index 0000000..b619619
--- /dev/null
@@ -0,0 +1,23 @@
+Upstream-Status: Backport
+
+ar.c (do_oper_delete): Fix num passed to memset
+native build failed as following on Fedora18+: 
+ar.c: In function 'do_oper_delete':
+ar.c:918:31: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
+   memset (found, '\0', sizeof (found));
+                                ^
+The original commit is http://git.fedorahosted.org/cgit/elfutils.git/commit/src/ar.c?id=1a4d0668d18bf1090c5c08cdb5cb3ba2b8eb5410
+
+Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
+
+--- elfutils-0.148/src/ar.c.org        2013-03-12 21:12:17.928281375 -0500
++++ elfutils-0.148/src/ar.c    2013-03-12 21:15:30.053285271 -0500
+@@ -915,7 +915,7 @@
+               long int instance)
+ {
+   bool *found = alloca (sizeof (bool) * argc);
+-  memset (found, '\0', sizeof (found));
++  memset (found, '\0', sizeof (bool) * argc);
+   /* List of the files we keep.  */
+   struct armem *to_copy = NULL;
index bc9e9c6ec2a8dfbb5df9d8841dc8e70e0d5d362d..e8d58fbde5135062081464da876740cd238d869c 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
                     file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
 DEPENDS = "libtool bzip2 zlib virtual/libintl"
 
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"
 
@@ -32,6 +32,7 @@ SRC_URI += "\
        file://fix_for_gcc-4.7.patch \
        file://dso-link-change.patch \
        file://nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch \
+       file://elfutils-ar-c-fix-num-passed-to-memset.patch \
 "
 # Only apply when building uclibc based target recipe
 SRC_URI_append_libc-uclibc = " file://uclibc-support.patch"