]> code.ossystems Code Review - openembedded-core.git/commitdiff
diffstat: exclude aclocal
authorRoss Burton <ross.burton@intel.com>
Tue, 8 Aug 2017 10:09:01 +0000 (11:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Aug 2017 11:52:17 +0000 (12:52 +0100)
Instead of moving aclocal.m4 to acinclude.m4 in a custom do_configure, simply
tell autoreconf not to run aclocal.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/diffstat/diffstat_1.61.bb

index 583b387e9573e975ff3e412c6c82f531908bea94..f8b7b06cf24a441f2d59d2ecbcdd7660a5078ac0 100644 (file)
@@ -18,14 +18,9 @@ S = "${WORKDIR}/diffstat-${PV}"
 
 inherit autotools gettext ptest
 
-LDFLAGS += "${TOOLCHAIN_OPTIONS}"
+EXTRA_AUTORECONF += "--exclude=aclocal"
 
-do_configure () {
-       if [ ! -e ${S}/acinclude.m4 ]; then
-               mv ${S}/aclocal.m4 ${S}/acinclude.m4
-       fi
-       autotools_do_configure
-}
+LDFLAGS += "${TOOLCHAIN_OPTIONS}"
 
 do_install_ptest() {
        cp -r ${S}/testing ${D}${PTEST_PATH}