]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-distribute: fix interpreter
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 27 Aug 2014 15:57:14 +0000 (08:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 28 Aug 2014 14:11:11 +0000 (15:11 +0100)
It should use "/usr/bin/env python3" rather than python.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-distribute_0.6.32.bb

index 573096cb1cc3baa5c6840f77c3eab9da685b17d9..0ef3a8762f7085686a976f14aeb08c12ae5e6ca7 100644 (file)
@@ -37,6 +37,8 @@ do_install_append() {
     rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
     mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
     echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
+    sed -i -e '1s|^#!.*python|#!/usr/bin/env python3|' \
+        ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
 }
 
 RDEPENDS_${PN} = "\