]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnu-config: upgrade from 20050701 to 20080123
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 21 Jun 2010 07:17:17 +0000 (00:17 -0700)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 1 Jul 2010 06:30:26 +0000 (23:30 -0700)
Rebased this patch for newer version:
 gnu-config/config-guess-uclibc.patch

Removed this patch as it's included in the new source:
 gnu-config/avr32.patch

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/packages/gnu-config/gnu-config/avr32.patch [deleted file]
meta/packages/gnu-config/gnu-config/config-guess-uclibc.patch
meta/packages/gnu-config/gnu-config_20080123.bb [moved from meta/packages/gnu-config/gnu-config_20050701.bb with 92% similarity]

diff --git a/meta/packages/gnu-config/gnu-config/avr32.patch b/meta/packages/gnu-config/gnu-config/avr32.patch
deleted file mode 100644 (file)
index 43efcd8..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- /tmp/config.sub    2007-06-01 15:29:41.000000000 +0200
-+++ config/config.sub  2007-06-01 15:58:50.005251000 +0200
-@@ -231,7 +231,7 @@
-       | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
-       | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
-       | am33_2.0 \
--      | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
-+      | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
-       | bfin \
-       | c4x | clipper \
-       | d10v | d30v | dlx | dsp16xx \
-@@ -305,7 +305,7 @@
-       | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
-       | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
-       | arm-*  | armbe-* | armle-* | armeb-* | armv*-* \
--      | avr-* \
-+      | avr-* | avr32-* \
-       | bfin-* | bs2000-* \
-       | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
-       | clipper-* | craynv-* | cydra-* \
index b322157e9b2a5ad7b9d325cc4bc7d4b20f12e59b..f820cef1c9870de1ef1cb08c07b6f183267e7dae 100644 (file)
@@ -1,12 +1,13 @@
 Patch courtesy gentoo-portage/sys-devel/gnuconfig/files/automake-1.8.5-config-guess-uclibc.patch.
 
 updated to 20050516 by Marcin 'Hrw' Juszkiewicz (by hand)
+updated to 20080123 by Nitin A Kamble (by hand)
 
 Index: config/config.guess
 ===================================================================
---- config.guess.original      2005-05-16 13:43:19 +0200
-+++ config.guess       2005-05-16 13:45:26 +0200
-@@ -138,6 +138,19 @@
+--- config.orig/config.guess
++++ config/config.guess
+@@ -139,6 +139,19 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` |
  UNAME_SYSTEM=`(uname -s) 2>/dev/null`  || UNAME_SYSTEM=unknown
  UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
  
@@ -26,16 +27,23 @@ Index: config/config.guess
  # Note: order is significant - the case branches are not exclusive.
  
  case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
-@@ -847,7 +860,7 @@
-       echo ${UNAME_MACHINE}-pc-minix
-       exit ;;
-     arm*:Linux:*:*)
+@@ -840,13 +853,13 @@ EOF
+       if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
+           | grep -q __ARM_EABI__
+       then
+-          echo ${UNAME_MACHINE}-unknown-linux-gnu
++          echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
+       else
+           echo ${UNAME_MACHINE}-unknown-linux-gnueabi
+       fi
+       exit ;;
+     avr32*:Linux:*:*)
 -      echo ${UNAME_MACHINE}-unknown-linux-gnu
 +      echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
        exit ;;
      cris:Linux:*:*)
        echo cris-axis-linux-gnu
-@@ -856,16 +869,16 @@
+@@ -855,16 +868,16 @@ EOF
        echo crisv32-axis-linux-gnu
        exit ;;
      frv:Linux:*:*)
@@ -56,22 +64,26 @@ Index: config/config.guess
        exit ;;
      mips:Linux:*:*)
        eval $set_cc_for_build
-@@ -884,7 +897,7 @@
-       #endif
- EOF
-       eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
+@@ -887,7 +900,7 @@ EOF
+               s: ::g
+               p
+           }'`"
 -      test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
 +      test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
        ;;
      mips64:Linux:*:*)
        eval $set_cc_for_build
-@@ -903,13 +916,13 @@
-       #endif
- EOF
-       eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
+@@ -910,16 +923,16 @@ EOF
+               s: ::g
+               p
+           }'`"
 -      test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
 +      test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
        ;;
+     or32:Linux:*:*)
+-      echo or32-unknown-linux-gnu
++      echo or32-unknown-linux-${LIBC}
+       exit ;;
      ppc:Linux:*:*)
 -      echo powerpc-unknown-linux-gnu
 +      echo powerpc-unknown-linux-${LIBC}
@@ -82,7 +94,7 @@ Index: config/config.guess
        exit ;;
      alpha:Linux:*:*)
        case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
-@@ -922,34 +935,34 @@
+@@ -932,40 +945,40 @@ EOF
          EV68*) UNAME_MACHINE=alphaev68 ;;
          esac
        objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
@@ -121,13 +133,20 @@ Index: config/config.guess
 -      echo ${UNAME_MACHINE}-unknown-linux-gnu
 +      echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
        exit ;;
+     vax:Linux:*:*)
+       echo ${UNAME_MACHINE}-dec-linux-gnu
+       exit ;;
      x86_64:Linux:*:*)
 -      echo x86_64-unknown-linux-gnu
 +      echo x86_64-unknown-linux-${LIBC}
        exit ;;
+     xtensa*:Linux:*:*)
+-      echo ${UNAME_MACHINE}-unknown-linux-gnu
++      echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
+       exit ;;
      i*86:Linux:*:*)
        # The BFD linker knows what the default object file format is, so
-@@ -964,20 +977,21 @@
+@@ -980,20 +993,21 @@ EOF
                                    p'`
          case "$ld_supported_targets" in
          elf32-i386)
similarity index 92%
rename from meta/packages/gnu-config/gnu-config_20050701.bb
rename to meta/packages/gnu-config/gnu-config_20080123.bb
index b8c8766ba2ece30ee9f30c8074f5be83b160bd11..5dc76524d36fbabebc8906c9319cb2a7afb0aa1d 100644 (file)
@@ -6,11 +6,10 @@ INHIBIT_DEFAULT_DEPS = "1"
 
 FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
 PV = "0.1+cvs${FIXEDSRCDATE}"
-PR = "r6"
+PR = "r0"
 
 SRC_URI = "cvs://anonymous@cvs.sv.gnu.org/cvsroot/config;module=config;method=pserver;date=${FIXEDSRCDATE} \
-          file://config-guess-uclibc.patch;patch=1 \
-           file://avr32.patch;patch=1 \
+          file://config-guess-uclibc.patch \
            file://gnu-configize.in"
 S = "${WORKDIR}/config"