]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update hostap packages from OE
authorRichard Purdie <richard@openedhand.com>
Thu, 23 Mar 2006 23:28:43 +0000 (23:28 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 23 Mar 2006 23:28:43 +0000 (23:28 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@330 311d38ba-8fff-0310-9ca6-ca027cbcb966

18 files changed:
openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig [deleted file]
openembedded/packages/hostap/hostap-daemon-0.4.4/init [deleted file]
openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff [deleted file]
openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff [deleted file]
openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig [deleted file]
openembedded/packages/hostap/hostap-modules.inc [new file with mode: 0644]
openembedded/packages/hostap/hostap-modules/Makefile.patch [moved from openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch with 100% similarity]
openembedded/packages/hostap/hostap-modules/add_event.patch [moved from openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch with 100% similarity]
openembedded/packages/hostap/hostap-modules/hostap-utsname.patch [moved from openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch with 100% similarity]
openembedded/packages/hostap/hostap-modules/hostap_cardid.patch [moved from openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch with 100% similarity]
openembedded/packages/hostap/hostap-modules/ipaq_compat.patch [moved from openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch with 100% similarity]
openembedded/packages/hostap/hostap-modules/kernel_updates.patch [new file with mode: 0644]
openembedded/packages/hostap/hostap-modules/mtx_compat.diff [moved from openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff with 100% similarity]
openembedded/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff [moved from openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff with 100% similarity]
openembedded/packages/hostap/hostap-modules_0.3.9.bb
openembedded/packages/hostap/hostap-utils.inc [new file with mode: 0644]
openembedded/packages/hostap/hostap-utils_0.3.7.bb
openembedded/packages/hostap/hostap-utils_0.4.0.bb

diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig b/openembedded/packages/hostap/hostap-daemon-0.4.4/defconfig
deleted file mode 100644 (file)
index d0e22f2..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Example hostapd build time configuration
-#
-# This file lists the configuration options that are used when building the
-# hostapd binary. All lines starting with # are ignored. Configuration option
-# lines must be commented out complete, if they are not to be included, i.e.,
-# just setting VARIABLE=n is not disabling that variable.
-#
-# This file is included in Makefile, so variables like CFLAGS and LIBS can also
-# be modified from here. In most cass, these lines should use += in order not
-# to override previous values of the variables.
-
-# Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
-
-# Driver interface for wired authenticator
-CONFIG_DRIVER_WIRED=y
-
-# Driver interface for madwifi driver
-#CONFIG_DRIVER_MADWIFI=y
-#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
-
-# Driver interface for Prism54 driver
-CONFIG_DRIVER_PRISM54=y
-
-# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
-#CONFIG_DRIVER_BSD=y
-#CFLAGS += -I/usr/local/include
-#LIBS += -L/usr/local/lib
-
-# IEEE 802.11F/IAPP
-CONFIG_IAPP=y
-
-# WPA2/IEEE 802.11i RSN pre-authentication
-CONFIG_RSN_PREAUTH=y
-
-# Integrated EAP authenticator
-CONFIG_EAP=y
-
-# EAP-MD5 for the integrated EAP authenticator
-CONFIG_EAP_MD5=y
-
-# EAP-TLS for the integrated EAP authenticator
-CONFIG_EAP_TLS=y
-
-# EAP-MSCHAPv2 for the integrated EAP authenticator
-CONFIG_EAP_MSCHAPV2=y
-
-# EAP-PEAP for the integrated EAP authenticator
-CONFIG_EAP_PEAP=y
-
-# EAP-GTC for the integrated EAP authenticator
-CONFIG_EAP_GTC=y
-
-# EAP-TTLS for the integrated EAP authenticator
-CONFIG_EAP_TTLS=y
-
-# EAP-SIM for the integrated EAP authenticator
-#CONFIG_EAP_SIM=y
-
-# PKCS#12 (PFX) support (used to read private key and certificate file from
-# a file that usually has extension .p12 or .pfx)
-CONFIG_PKCS12=y
-
-# RADIUS authentication server. This provides access to the integrated EAP
-# authenticator from external hosts using RADIUS.
-CONFIG_RADIUS_SERVER=y
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/init b/openembedded/packages/hostap/hostap-daemon-0.4.4/init
deleted file mode 100644 (file)
index b0736c0..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/sh
-DAEMON=/usr/sbin/hostapd
-NAME=httpd
-DESC="HOSTAP Daemon"
-ARGS="/etc/hostapd.conf"
-
-test -f $DAEMON || exit 0
-
-set -e
-
-case "$1" in
-    start)
-        echo -n "starting $DESC: $NAME... "
-       start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
-       echo "done."
-       ;;
-    stop)
-        echo -n "stopping $DESC: $NAME... "
-       start-stop-daemon -K -n $NAME
-       echo "done."
-       ;;
-    restart)
-        echo "restarting $DESC: $NAME... "
-       $0 stop
-       $0 start
-       echo "done."
-       ;;
-    reload)
-       echo -n "reloading $DESC: $NAME... "
-       killall -HUP $(basename ${DAEMON})
-       echo "done."
-       ;;
-    *)
-       echo "Usage: $0 {start|stop|restart|reload}"
-       exit 1
-       ;;
-esac
-
-exit 0
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff b/openembedded/packages/hostap/hostap-daemon-0.4.4/madwifi-bsd-fix.diff
deleted file mode 100644 (file)
index d9dab26..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- driver_madwifi.c.orig      2005-03-18 15:12:53.392793216 +0100
-+++ driver_madwifi.c   2005-03-18 15:13:09.246383104 +0100
-@@ -21,7 +21,8 @@
- #include <sys/types.h>
- #include <sys/socket.h>
--#include <include/compat.h>
-+#include <net80211/compat.h>
-+#include <net80211/_ieee80211.h>
- #include <net80211/ieee80211.h>
- #include <net80211/ieee80211_crypto.h>
- #include <net80211/ieee80211_ioctl.h>
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff b/openembedded/packages/hostap/hostap-daemon-0.4.4/makefile-cross.diff
deleted file mode 100644 (file)
index 25d2ca3..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.orig      2005-03-18 14:34:27.274376504 +0100
-+++ Makefile   2005-03-18 14:35:56.609795456 +0100
-@@ -1,7 +1,9 @@
--CC=gcc
-+CC?=gcc
- DIR_WPA_SUPPLICANT=.
- DIR_HOSTAP=.
-+TARGET_PREFIX ?= /usr/local/bin/
-+
- ifndef CFLAGS
- CFLAGS = -MMD -O2 -Wall -g
- endif
-@@ -170,10 +172,10 @@
-       fi
- install: all
--      for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
-+      for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
- hostapd: $(OBJS)
--      $(CC) -o hostapd $(OBJS) $(LIBS)
-+      $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
- driver_conf.c: Makefile .config
-       rm -f driver_conf.c
diff --git a/openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig b/openembedded/packages/hostap/hostap-daemon-0.4.4/mtx-1/defconfig
deleted file mode 100644 (file)
index 8c3065c..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Example hostapd build time configuration
-#
-# This file lists the configuration options that are used when building the
-# hostapd binary. All lines starting with # are ignored. Configuration option
-# lines must be commented out complete, if they are not to be included, i.e.,
-# just setting VARIABLE=n is not disabling that variable.
-#
-# This file is included in Makefile, so variables like CFLAGS and LIBS can also
-# be modified from here. In most cass, these lines should use += in order not
-# to override previous values of the variables.
-
-# Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
-
-# Driver interface for wired authenticator
-CONFIG_DRIVER_WIRED=y
-
-# Driver interface for madwifi driver
-CONFIG_DRIVER_MADWIFI=y
-#CFLAGS += -I../head # change to reflect local setup; directory for madwifi src
-
-# Driver interface for Prism54 driver
-CONFIG_DRIVER_PRISM54=y
-
-# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
-#CONFIG_DRIVER_BSD=y
-#CFLAGS += -I/usr/local/include
-#LIBS += -L/usr/local/lib
-
-# IEEE 802.11F/IAPP
-CONFIG_IAPP=y
-
-# WPA2/IEEE 802.11i RSN pre-authentication
-CONFIG_RSN_PREAUTH=y
-
-# Integrated EAP authenticator
-CONFIG_EAP=y
-
-# EAP-MD5 for the integrated EAP authenticator
-CONFIG_EAP_MD5=y
-
-# EAP-TLS for the integrated EAP authenticator
-CONFIG_EAP_TLS=y
-
-# EAP-MSCHAPv2 for the integrated EAP authenticator
-CONFIG_EAP_MSCHAPV2=y
-
-# EAP-PEAP for the integrated EAP authenticator
-CONFIG_EAP_PEAP=y
-
-# EAP-GTC for the integrated EAP authenticator
-CONFIG_EAP_GTC=y
-
-# EAP-TTLS for the integrated EAP authenticator
-CONFIG_EAP_TTLS=y
-
-# EAP-SIM for the integrated EAP authenticator
-#CONFIG_EAP_SIM=y
-
-# PKCS#12 (PFX) support (used to read private key and certificate file from
-# a file that usually has extension .p12 or .pfx)
-CONFIG_PKCS12=y
-
-# RADIUS authentication server. This provides access to the integrated EAP
-# authenticator from external hosts using RADIUS.
-CONFIG_RADIUS_SERVER=y
diff --git a/openembedded/packages/hostap/hostap-modules.inc b/openembedded/packages/hostap/hostap-modules.inc
new file mode 100644 (file)
index 0000000..72f2dc2
--- /dev/null
@@ -0,0 +1,44 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PROVIDES = "hostap-conf"
+RPROVIDES = "virtual/kernel-hostap"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+          file://hostap_cs.conf"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+       file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
+
+do_install() {
+       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+                  ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+                  ${D}${sysconfdir}/pcmcia
+       for i in ${NET_MODULES}
+       do
+               install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+       done
+       install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+       install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+       cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"
+RPROVIDES_hostap-modules-cs = "hostap-conf"
diff --git a/openembedded/packages/hostap/hostap-modules/kernel_updates.patch b/openembedded/packages/hostap/hostap-modules/kernel_updates.patch
new file mode 100644 (file)
index 0000000..70487a9
--- /dev/null
@@ -0,0 +1,192 @@
+Index: hostap-driver-0.4.4/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.4.4.orig/driver/modules/hostap_cs.c        2005-08-21 20:23:21.000000000 +0100
++++ hostap-driver-0.4.4/driver/modules/hostap_cs.c     2005-09-17 17:09:05.000000000 +0100
+@@ -207,12 +207,17 @@
+ #include "hostap_hw.c"
+-
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static void prism2_detach(dev_link_t *link);
++#else
++static void prism2_detach(struct pcmcia_device *p_dev);
++#endif
++
+ static void prism2_release(u_long arg);
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static int prism2_event(event_t event, int priority,
+                       event_callback_args_t *args);
+-
++#endif
+ static int prism2_pccard_card_present(local_info_t *local)
+ {
+@@ -508,25 +513,36 @@
+ }
+ #endif
++static int prism2_config(dev_link_t *link);
+ /* allocate local data and register with CardServices
+  * initialize dev_link structure, but do not configure the card yet */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static dev_link_t *prism2_attach(void)
++#else
++static int prism2_attach(struct pcmcia_device *p_dev)
++#endif
+ {
+       dev_link_t *link;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+       client_reg_t client_reg;
+       int ret;
++#endif
+       link = kmalloc(sizeof(dev_link_t), GFP_KERNEL);
+       if (link == NULL)
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+               return NULL;
+-
++#else
++              return -ENOMEM;
++#endif
+       memset(link, 0, sizeof(dev_link_t));
+       PDEBUG(DEBUG_HW, "%s: setting Vcc=33 (constant)\n", dev_info);
+       link->conf.Vcc = 33;
+       link->conf.IntType = INT_MEMORY_AND_IO;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+       /* register with CardServices */
+       link->next = dev_list;
+       dev_list = link;
+@@ -547,12 +563,28 @@
+               prism2_detach(link);
+               return NULL;
+       }
++
+       return link;
+-}
++#else
++      link->handle = p_dev;
++      p_dev->instance = link;
++
++      link->state |= DEV_PRESENT | DEV_CONFIG_PENDING;
++      prism2_config(link);
++      return 0;
++#endif
++}
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static void prism2_detach(dev_link_t *link)
++#else
++static void prism2_detach(struct pcmcia_device *p_dev)
++#endif
+ {
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++      dev_link_t *link = dev_to_instance(p_dev);
++#endif
+       dev_link_t **linkp;
+       PDEBUG(DEBUG_FLOW, "prism2_detach\n");
+@@ -570,6 +602,7 @@
+               prism2_release((u_long)link);
+       }
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+       if (link->handle) {
+               int res = pcmcia_deregister_client(link->handle);
+               if (res) {
+@@ -577,6 +610,7 @@
+                       cs_error(link->handle, DeregisterClient, res);
+               }
+       }
++#endif
+       *linkp = link->next;
+       /* release net devices */
+@@ -855,7 +889,53 @@
+       PDEBUG(DEBUG_FLOW, "release - done\n");
+ }
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++static int prism2_suspend1(struct pcmcia_device *dev)
++{
++      dev_link_t *link = dev_to_instance(dev);
++      struct net_device *ndev = (struct net_device *) link->priv;
++
++      PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_SUSPEND\n", dev_info);
++      link->state |= DEV_SUSPEND;
++      /* fall through */
++      if (link->state & DEV_CONFIG) {
++              if (link->open) {
++                      netif_stop_queue(ndev);
++                      netif_device_detach(ndev);
++              }
++              prism2_suspend(ndev);
++              pcmcia_release_configuration(link->handle);
++      }
++
++      return 0;
++}
++
++static int prism2_resume1(struct pcmcia_device *dev)
++{
++      dev_link_t *link = dev_to_instance(dev);
++      struct net_device *ndev = (struct net_device *) link->priv;
++
++      PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_RESUME\n", dev_info);
++
++      link->state &= ~DEV_SUSPEND;
++      /* fall through */
++
++      if (link->state & DEV_CONFIG) {
++              pcmcia_request_configuration(link->handle, &link->conf);
++              prism2_hw_shutdown(ndev, 1);
++              prism2_hw_config(ndev, link->open ? 0 : 1);
++              if (link->open) {
++                      netif_device_attach(ndev);
++                      netif_start_queue(ndev);
++              }
++      }
++
++      return 0;
++}
++#endif
++
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static int prism2_event(event_t event, int priority,
+                       event_callback_args_t *args)
+ {
+@@ -924,7 +1004,7 @@
+       }
+       return 0;
+ }
+-
++#endif
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
+@@ -983,11 +1063,20 @@
+       .drv            = {
+               .name   = "hostap_cs",
+       },
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++      .probe          = prism2_attach,
++      .remove         = prism2_detach,
++      .suspend        = prism2_suspend1,
++      .resume         = prism2_resume1,
++#else
+       .attach         = prism2_attach,
+       .detach         = prism2_detach,
++#endif
+       .owner          = THIS_MODULE,
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+       .event          = prism2_event,
++#endif
+       .id_table       = hostap_cs_ids,
+ #endif
+ };
index 940b23863b4b09e73a61803ee785421791df52fe..508c6532307cbdb250f029d2b447e14cbe01103e 100644 (file)
@@ -1,48 +1,7 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-PROVIDES = "virtual/kernel-hostap hostap-conf"
-PR = "r8"
+include hostap-modules.inc
+PR = "r9"
 
-SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
-           file://hostap_cs.conf \
-          file://Makefile.patch;patch=1 \
-          file://add_event.patch;patch=1 \
-          file://hostap-utsname.patch;patch=1 \
-          file://hostap_cardid.patch;patch=1"
-SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
-       file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
-SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
-
-S = "${WORKDIR}/hostap-driver-${PV}"
-
-inherit module
-
-# Hack Alert :D
-ARCH_mipsel = "mips"
-MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
-
-NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
-
-do_install() {
-       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
-                  ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
-                  ${D}${sysconfdir}/pcmcia
-       for i in ${NET_MODULES}
-       do
-               install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
-       done
-       install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
-       install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
-       cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
-}
-
-PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
-FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
-FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
-FILES_hostap-modules = "/lib/modules/"
-RDEPENDS_hostap-modules-cs = "hostap-modules"
-RDEPENDS_hostap-modules-pci = "hostap-modules"
-RPROVIDES_hostap-modules-cs = "hostap-conf"
+SRC_URI += "file://Makefile.patch;patch=1 \
+           file://add_event.patch;patch=1 \
+           file://hostap-utsname.patch;patch=1 \
+           file://hostap_cardid.patch;patch=1"
diff --git a/openembedded/packages/hostap/hostap-utils.inc b/openembedded/packages/hostap/hostap-utils.inc
new file mode 100644 (file)
index 0000000..c5c5d5b
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RRECOMMENDS = "virtual/kernel-hostap"
+PR = "r3"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+          file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+           hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+       install -d ${D}${sbindir}/
+       for f in ${BINARIES}
+       do
+               install -m 0755 $f ${D}${sbindir}/
+       done
+}
+
index cdfb0c1e3eb9491b86c8e3fb34bc3ed8c477ff39..ad06cd3d6d92170bd8d9a6bedcffcebe012f9006 100644 (file)
@@ -1,24 +1,3 @@
-DESCRIPTION = "User mode helpers for the hostap driver"
-HOMEPAGE = "http://hostap.epitest.fi"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-RDEPENDS = "virtual/kernel-hostap"
-PR = "r2"
-
-SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
-          file://hostap-fw-load.patch;patch=1"
-S = "${WORKDIR}/hostap-utils-${PV}"
-
-BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
-           hostap_rid prism2_param prism2_srec split_combined_hex"
-
-do_install() {
-       install -d ${D}${sbindir}/
-       for f in ${BINARIES}
-       do
-               install -m 0755 $f ${D}${sbindir}/
-       done
-}
+include hostap-utils.inc
 
+PR = "r3"
index 98254602aa6ebdf27c99fa433c6f1d66f90983df..ad06cd3d6d92170bd8d9a6bedcffcebe012f9006 100644 (file)
@@ -1,25 +1,3 @@
-DESCRIPTION = "User mode helpers for the hostap driver"
-HOMEPAGE = "http://hostap.epitest.fi"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-DEPENDS = "virtual/kernel-hostap"
-RRECOMMENDS = "virtual/kernel-hostap"
-PR = "r3"
-
-SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
-          file://hostap-fw-load.patch;patch=1"
-S = "${WORKDIR}/hostap-utils-${PV}"
-
-BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
-           hostap_rid prism2_param prism2_srec split_combined_hex"
-
-do_install() {
-       install -d ${D}${sbindir}/
-       for f in ${BINARIES}
-       do
-               install -m 0755 $f ${D}${sbindir}/
-       done
-}
+include hostap-utils.inc
 
+PR = "r3"