]> code.ossystems Code Review - openembedded-core.git/commitdiff
stage-manager: copy files, don't move them
authorRichard Purdie <richard@openedhand.com>
Sun, 25 Nov 2007 15:39:51 +0000 (15:39 +0000)
committerRichard Purdie <richard@openedhand.com>
Sun, 25 Nov 2007 15:39:51 +0000 (15:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3233 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/stage-manager/files/stage-manager
meta/packages/stage-manager/stagemanager-native_0.0.1.bb

index 733a0a4f721195ff69fee9122a94f3733fd14474..06495dbb0296691dc5d346d99545e2944c561370 100755 (executable)
@@ -93,7 +93,7 @@ if __name__ == "__main__":
                 if options.copydir:
                     copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
                     mkdirhier(os.path.split(copypath)[0])
-                    os.system("mv " + path + " " + copypath)
+                    os.system("cp " + path + " " + copypath)
                     found = True
             else:
                 if cache[path]['ts'] != fstamp[stat.ST_MTIME] or cache[path]['size'] != fstamp[stat.ST_SIZE]:
@@ -104,7 +104,7 @@ if __name__ == "__main__":
                    if options.copydir:
                         copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
                         mkdirhier(os.path.split(copypath)[0])
-                        os.system("mv " + path + " " + copypath)
+                        os.system("cp " + path + " " + copypath)
                         found = True
 
     if options.update:
index 7074d37307ab07a67b58f9f2490de6caaa7d6f93..b1f336720958f905f99fcbb13fb5113eb522e902 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "file://stage-manager"
 LICENSE = "GPLv2"