]> code.ossystems Code Review - openembedded-core.git/commitdiff
cdrtools-native: Don't set uid/gid during install
authorPaul Barker <paul@betafive.co.uk>
Fri, 15 Nov 2019 13:00:48 +0000 (13:00 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Nov 2019 21:17:40 +0000 (21:17 +0000)
This is a native recipe so won't be installed as root.

If the string 'root' is part of the username then the install script
can get tricked into thinking we are root (regardless of the actual
uid or permissions) resulting in attempts to run chown/chgrp
inappropriately.

Signed-off-by: Paul Barker <paul@betafive.co.uk>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cdrtools/cdrtools-native_3.01.bb
meta/recipes-devtools/cdrtools/cdrtools/0001-Don-t-set-uid-gid-during-install.patch [new file with mode: 0644]

index 78e1565e47429c2cd0fc35ae9ac2152d75e93f68..1c602e7ce7d2d08e3eae71302eb0ea590174970e 100644 (file)
@@ -7,7 +7,10 @@ SECTION = "console/utils"
 LICENSE = "GPLv2 & CDDL-1.0 & LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=32f68170be424c2cd64804337726b312"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/cdrtools/cdrtools-${REALPV}.tar.bz2"
+SRC_URI = " \
+       ${SOURCEFORGE_MIRROR}/project/cdrtools/cdrtools-${REALPV}.tar.bz2 \
+       file://0001-Don-t-set-uid-gid-during-install.patch \
+       "
 UPSTREAM_VERSION_UNKNOWN = "1"
 
 SRC_URI[md5sum] = "7d45c5b7e1f78d85d1583b361aee6e8b"
diff --git a/meta/recipes-devtools/cdrtools/cdrtools/0001-Don-t-set-uid-gid-during-install.patch b/meta/recipes-devtools/cdrtools/cdrtools/0001-Don-t-set-uid-gid-during-install.patch
new file mode 100644 (file)
index 0000000..9d38294
--- /dev/null
@@ -0,0 +1,27 @@
+From 529cd5b007aa681c3ca14e5ab1e30469dd51646b Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul@betafive.co.uk>
+Date: Tue, 12 Nov 2019 22:17:19 +0000
+Subject: [PATCH] Don't set uid/gid during install
+
+Signed-off-by: Paul Barker <paul@betafive.co.uk>
+Upstream-Status: Inappropriate [native]
+---
+ RULES/rules.prg | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/RULES/rules.prg b/RULES/rules.prg
+index 023555c..f70f1a7 100644
+--- a/RULES/rules.prg
++++ b/RULES/rules.prg
+@@ -94,7 +94,7 @@ INSGRP=              $(__DEFINSGRP:$(_UNIQ)%=%)
+ LD=           @echo " ==> LINKING   \"$@\""; ld
+ LOCALIZE=     @echo " ==> LOCALIZING \"$@\""; $(RM_F) $@; cp
+-INSTALL=      @echo " ==> INSTALLING \"$@\""; sh $(SRCROOT)/conf/install-sh -c -m $(INSMODEINS) -o $(INSUSR) -g $(INSGRP)
++INSTALL=      @echo " ==> INSTALLING \"$@\""; sh $(SRCROOT)/conf/install-sh -c -m $(INSMODEINS)
+ CHMOD=                @echo " ==> SETTING PERMISSIONS ON \"$@\""; chmod
+ CHOWN=                @echo " ==> SETTING OWNER ON \"$@\""; chown
+ CHGRP=                @echo " ==> SETTING GROUP ON \"$@\""; chgrp
+-- 
+2.24.0
+