]> code.ossystems Code Review - openembedded-core.git/commitdiff
cogl: kms: include necessary header for size_t
authorAndreas Oberritter <obi@opendreambox.org>
Tue, 28 Jan 2014 20:27:54 +0000 (21:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jan 2014 17:37:15 +0000 (17:37 +0000)
Fixes compilation in cases where stddef.h is not already
included by EGL headers.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch [new file with mode: 0644]

index 5e5c82b50123d722fe7fb8a2867e9ba2b1690854..0ef972622c4b48ab248c7c2f45932e26aa597cc3 100644 (file)
@@ -2,5 +2,7 @@ require cogl-1.0.inc
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
 
+SRC_URI += "file://kms-include-stddef.h-before-drm.h.patch"
+
 SRC_URI[archive.md5sum] = "611a61bed04354cbfffa3dc27feb6d4f"
 SRC_URI[archive.sha256sum] = "75c2c4636a050fda7ee8722ce3d9c618b08799ed92bbb72b4fdff3e73b096094"
diff --git a/meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch b/meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch
new file mode 100644 (file)
index 0000000..7cce279
--- /dev/null
@@ -0,0 +1,33 @@
+Upstream-Status: Submitted [cogl@lists.freedesktop.org]
+
+From 5e4f4689308732a0570a1631169247157c59f064 Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@saftware.de>
+Date: Tue, 28 Jan 2014 18:36:04 +0100
+Subject: [PATCH] kms: include stddef.h before drm.h
+
+Not doing so leads to the following error, if stddef.h is not included
+indirectly through EGL headers:
+
+| libdrm/drm.h:132:2: error: unknown type name 'size_t'
+|   size_t name_len;   /**< Length of name buffer */
+
+Signed-off-by: Andreas Oberritter <obi@saftware.de>
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index f7c9cfb..144ad9b 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -40,6 +40,7 @@
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <stddef.h>
+ #include <drm.h>
+ #include <xf86drm.h>
+ #include <xf86drmMode.h>
+-- 
+1.8.3.2
+