]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-dummy: provide kernel-modules (empty) package
authorMatthieu Crapet <Matthieu.Crapet@ingenico.com>
Wed, 19 Mar 2014 15:46:09 +0000 (16:46 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Mar 2014 12:05:29 +0000 (12:05 +0000)
Like it is done in kernel.bbclass

Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-dummy.bb

index bab1ac1c0c68d7edc7ed99196e1a4b50767a75c2..5d29f5cc12c8306448aabaa521183c8f1bd15940 100644 (file)
@@ -1,16 +1,22 @@
-SECTION = "kernel"
 SUMMARY = "Dummy Linux kernel"
 DESCRIPTION = "Dummy Linux kernel, to be selected as the preferred \
 provider for virtual/kernel to satisfy dependencies for situations \
 where you wish to build the kernel externally from the build system."
-LICENSE = "GPLv2"
+SECTION = "kernel"
 
+LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
 
 PROVIDES += "virtual/kernel"
 
 PACKAGES_DYNAMIC += "^kernel-module-.*"
 PACKAGES_DYNAMIC += "^kernel-image-.*"
+PACKAGES_DYNAMIC += "^kernel-firmware-.*"
+
+PACKAGES += "kernel-modules"
+FILES_kernel-modules = ""
+ALLOW_EMPTY_kernel-modules = "1"
+DESCRIPTION_kernel-modules = "Kernel modules meta package"
 
 #COMPATIBLE_MACHINE = "your_machine"
 
@@ -20,19 +26,19 @@ SRC_URI = "file://COPYING.GPL"
 S = "${WORKDIR}"
 
 do_configure() {
-        :
+       :
 }
 
 do_compile () {
-        :
+       :
 }
 
 do_install() {
-        :
+       :
 }
 
 do_bundle_initramfs() {
-        :
+       :
 }
 
 do_deploy() {