]> code.ossystems Code Review - openembedded-core.git/commitdiff
piglit: don't use /tmp to write generated sources to
authorRoss Burton <ross.burton@intel.com>
Tue, 2 Feb 2016 22:41:54 +0000 (22:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Feb 2016 23:19:37 +0000 (23:19 +0000)
If there are multiple builds on the same machine then piglit writing it's
generated sources to /tmp will race.  Instead, export TEMP to tell the tempfile
module to use a temporary directory under ${B}.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/piglit/piglit_git.bb

index e0bd1fe4331aa817a6dd7112d7fdf0e46bb2bdd5..4858652200d60e89f2d0b3d1a6f03c50f397698c 100644 (file)
@@ -18,6 +18,12 @@ inherit cmake pythonnative distro_features_check
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"
 
+# The built scripts go into the temporary directory according to tempfile
+# (typically /tmp) which can race if multiple builds happen on the same machine,
+# so tell it to use a directory in ${B} to avoid overwriting.
+export TEMP = "${B}/temp/"
+do_compile[dirs] =+ "${B}/temp/"
+
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"