]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: Add texinfo (for makeinfo)
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Apr 2016 15:16:42 +0000 (16:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 5 Apr 2016 08:55:47 +0000 (09:55 +0100)
Initially I was reluctant to do this however makeinfo is a dependency
of the buildsystem and only adds around 400kb to the buildtools-tarball
so it likely makes sense to add it. This allows people to use
the project on older environments.

Need to enable nativesdk-texinfo but this seems straightforward.

[YOCTO #8990]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/buildtools-tarball.bb
meta/recipes-extended/texinfo/texinfo_6.0.bb

index 8ad4e91ae403add87657dd49826f73607c4aeb72..9e0539031d1c40be3e09fd986dcc4aabf7d5c16e 100644 (file)
@@ -23,6 +23,7 @@ TOOLCHAIN_HOST_TASK ?= "\
     nativesdk-make \
     nativesdk-wget \
     nativesdk-ca-certificates \
+    nativesdk-texinfo \
     "
 
 SDK_PACKAGE_ARCHS =+ "buildtools-dummy-${SDKPKGSUFFIX}"
index a8702cfca60e49fbdaf0e9999f380aa412cc76e7..8638bb1d0d8f0f7ba7378179f06b7eb2f353041e 100644 (file)
@@ -79,4 +79,4 @@ FILES_${PN}-doc = "${infodir}/texinfo* \
                    ${datadir}/${tex_texinfo} \
                    ${mandir}/man1 ${mandir}/man5"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"