]> code.ossystems Code Review - openembedded-core.git/commitdiff
kea: no need to depend on kea-native
authorRoss Burton <ross@burtonini.com>
Thu, 3 Sep 2020 20:31:51 +0000 (21:31 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 5 Sep 2020 21:18:12 +0000 (22:18 +0100)
kea-msg-compiler is only needed if you alter the messages and the
generated sources need to be rebuilt.  When this is the case, there are
better ways to build kea-msg-compiler that don't involve building all of
Kea.

Don't depend on kea-native, remove BBCLASSEXTEND=native, and the target
overrides.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/kea/kea_1.7.7.bb

index e25f8e6fb0baf3b27bcd0bcc1ca211786ad7092b..c69a1808330e8ce5dd6cd5074884b02c36b2d022 100644 (file)
@@ -5,8 +5,6 @@ SECTION = "connectivity"
 LICENSE = "MPL-2.0 & Apache-2.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=68d95543d2096459290a4e6b9ceccffa"
 
-DEPENDS += "kea-native"
-
 SRC_URI = "\
     http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
     file://0001-remove-AC_TRY_RUN.patch \
@@ -32,16 +30,14 @@ DEBUG_OPTIMIZATION_append_mipsel = " -O"
 BUILD_OPTIMIZATION_remove_mipsel = " -Og"
 BUILD_OPTIMIZATION_append_mipsel = " -O"
 
-do_configure_prepend_class-target() {
-    mkdir -p ${B}/src/lib/log/compiler/
-    ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
+do_configure_prepend() {
     # replace abs_top_builddir to avoid introducing the build path
     # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
     find ${S} -type f -name *.sh.in | xargs sed -i  "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
     sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
 }
 
-do_install_append_class-target() {
+do_install_append() {
     install -d ${D}${systemd_system_unitdir}
     install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
     sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
@@ -62,6 +58,4 @@ PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
 FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
 FILES_${PN} += "${libdir}/hooks/*.so"
 
-BBCLASSEXTEND += "native"
-
 PARALLEL_MAKEINST = ""