]> code.ossystems Code Review - openembedded-core.git/commitdiff
lz4: fix CC
authorRobert Yang <liezhi.yang@windriver.com>
Mon, 24 Feb 2014 09:35:55 +0000 (04:35 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 24 Feb 2014 11:57:28 +0000 (11:57 +0000)
It defined the CC to ${TARGET_PREFIX}gcc which lost the --sysroot and was
incorrect, it would cause unexpected errors, we should define it as CC=${CC}.

[YOCTO #5869]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/lz4/lz4_svn.bb

index a760313daf34491d0a0ebb3f565cd9bf59bf422a..38e36d8256b758dbf2f569d820a350233ec4687a 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI = "svn://lz4.googlecode.com/svn/;module=trunk;protocol=http"
 
 S = "${WORKDIR}/trunk"
 
-EXTRA_OEMAKE = "PREFIX=${prefix} CC=${TARGET_PREFIX}gcc DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
 
 do_install() {
        oe_runmake install