]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/kernel-manual/Makefile: Added code to create a PDF version.
authorScott Rifenbark <scott.m.rifenbark@intel.com>
Thu, 25 Nov 2010 00:49:33 +0000 (16:49 -0800)
committerSaul Wold <Saul.Wold@intel.com>
Sat, 11 Dec 2010 06:01:13 +0000 (22:01 -0800)
Code now calls a new file called kernel-manual.xml that in turn
includes the yocto-project-kernel-manual.xml file.  This is in line
with how the other docs are built.

Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
documentation/kernel-manual/Makefile

index 4daeaeb47cb7514251dfffe3311131f5aacfdacf..57cfef2ef8394e01490592f938485ad68a624641 100644 (file)
@@ -1,10 +1,20 @@
 XSLTOPTS = --stringparam html.stylesheet style.css \
+           --stringparam  chapter.autolabel 1 \
+           --stringparam  appendix.autolabel A \
+           --stringparam  section.autolabel 1 \
+           --stringparam  section.label.includes.component.label 1 \
          --xinclude
 
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
 XSL_BASE_URI  = http://docbook.sourceforge.net/release/xsl/current
 XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
 
-all: html tarball
+all: html pdf tarball
+
+pdf:
+       ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
 
 ##
 # These URI should be rewritten by your distribution's xml catalog to
@@ -14,15 +24,15 @@ html:
 #       See http://www.sagehill.net/docbookxsl/HtmlOutput.html 
 
 #      xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
-       xsltproc $(XSLTOPTS) -o yocto-project-kernel-manual.html yocto-project-kernel-manual-customization.xsl yocto-project-kernel-manual.xml
+       xsltproc $(XSLTOPTS) -o yocto-project-kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
 
 tarball: html
-       tar -cvzf yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html style.css figures/yocto-project-transp.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+       tar -cvzf yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html style.css figures/kernel-title.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
 
 validate:
        xmllint --postvalid --xinclude --noout yocto-project-kernel-manual.xml
 
-OUTPUTS = yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html
+OUTPUTS = yocto-project-kernel-manual.tgz yocto-project-kernel-manual.html yocto-project-kernel-manual.pdf
 SOURCES = *.png *.xml *.css
 
 publish: