]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4-tools-native: Fix compile failures
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 6 Oct 2010 14:17:14 +0000 (15:17 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 6 Oct 2010 14:17:14 +0000 (15:17 +0100)
fontconfig/freetype are not listed in the dependencies, neither are any of the
X components yet this recipe appears to be building the whole UI framework, not
just the tools.

It turns out this is a dependency for uic3 and qdbus. Since at this time we don't
require these, remove them from the build.

Its likely cross versions of those specific tools would need to be added due to
their dependency on the windowing system compilation.

[BUGID #390]

Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/recipes-qt/qt4/qt4-tools-native.inc
meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb

index 7621d629f118c4d8c6518350b6dacfe9126c2777..9c78e7cd5ec0f717f6dfc71b7404aa3dcdf4827b 100644 (file)
@@ -43,11 +43,8 @@ TOBUILD = "\
   src/tools/uic \
   src/tools/rcc \
   src/network \
-  src/gui \
-  src/tools/uic3 \
   tools/linguist/lrelease \
   tools/linguist/lupdate \
-  tools/qdbus \
 "
 
 do_compile() {
@@ -61,7 +58,7 @@ NATIVE_INSTALL_WORKS = "1"
 do_install() {
        install -d ${D}${bindir}/
        install -m 0755 bin/qmake ${D}${bindir}/qmake2
-       for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
+       for i in moc uic rcc lrelease lupdate; do
                install -m 0755 bin/${i} ${D}${bindir}/${i}4
        done
 
index de24b38dea15503dcb1d0b3cf4d270e821ce2bb8..ac66eb3d5af193ba8f725ae6c2c7915441ef472d 100644 (file)
@@ -4,8 +4,8 @@ LICENSE = "LGPLv2.1 | GPLv3"
 LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
                     file://LICENSE.GPL3;md5=babc5b6b77441da277f5c06b2e547720 \
                     file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
-PR = "r0"
+PR = "r2"
 
-EXTRA_OECONF += " -no-fast -silent -no-rpath"
+EXTRA_OECONF += " -no-fast -silent -no-rpath -no-freetype -no-fontconfig"
 
 TOBUILD := "src/tools/bootstrap ${TOBUILD}"