]> code.ossystems Code Review - openembedded-core.git/commitdiff
git: depend on native perl and use it
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 30 Sep 2008 11:40:52 +0000 (11:40 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 30 Sep 2008 11:40:52 +0000 (11:40 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5335 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/git/git-native_1.5.4.4.bb
meta/packages/git/git.inc

index 935c773c1c1751def4244951391ea622ef0258d6..69f6f014c6137e020716ecaf93e8256f2f2bdcea 100644 (file)
@@ -1,4 +1,4 @@
 require git.inc
 inherit native
-DEPENDS = "openssl-native curl-native zlib-native expat-native"
-PR = "r1"
+DEPENDS += "openssl-native curl-native zlib-native expat-native"
+PR = "r2"
index 7115d44b353c6ea900fbd50db6168e4d5320f175..3e8781158244f081da3d2cbbd217a9442d4af9b5 100644 (file)
@@ -1,12 +1,13 @@
 DESCRIPTION = "The git revision control system used by the Linux kernel developers"
 SECTION = "console/utils"
 LICENSE = "GPL"
+DEPENDS = "perl-native"
 
 SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
            file://autotools.patch;patch=1"
 S = "${WORKDIR}/git-${PV}"
 
-EXTRA_OEMAKE = "NO_TCLTL=1"
+EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl --without-tcltk"
 
 inherit autotools