]> code.ossystems Code Review - openembedded-core.git/commitdiff
apmd: use ${HOST_SYS}-libtool
authorAndrew Gabbasov <andrew_gabbasov@mentor.com>
Wed, 28 Sep 2011 12:07:58 +0000 (16:07 +0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 Sep 2011 20:38:30 +0000 (21:38 +0100)
libtool-cross uses ${HOST_SYS}- prefix while building and installing.
In some cases that may be different from ${TARGET_PREFIX}, that is currently
used in apmd recipe. It's better to have them consistent.

Signed-off-by: Andrew Gabbasov <andrew_gabbasov@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/apmd/apmd_3.2.2-14.bb

index e80e108ca51c04a970f5e8a0eb8ee685aa464d2e..bf53cc650a50208c06db226192cd23968ca68411 100644 (file)
@@ -34,7 +34,7 @@ INITSCRIPT_PARAMS = "defaults"
 
 do_compile() {
        # apmd doesn't use whole autotools. Just libtool for installation
-       oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool" apm apmd
+       oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" apm apmd
 }
 
 do_install() {