]> code.ossystems Code Review - openembedded-core.git/commitdiff
Disable build qt related packagegroups on mips64 with 64 bits userspace
authorKai Kang <kai.kang@windriver.com>
Fri, 28 Jun 2013 07:48:47 +0000 (15:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 28 Jun 2013 15:32:02 +0000 (16:32 +0100)
Because qt could not be built on mips64 with 64 bits userspace, set
COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
with 64 bit userspace too.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc

index 315df3388d80c16c4ffc4f0d9725d14f4f805e19..c993242b727fd0f4d68c26e70f02e1825b5f3045 100644 (file)
@@ -6,6 +6,9 @@ DESCRIPTION = "Qt package groups"
 LICENSE = "MIT"
 PR = "r4"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 PACKAGES = "${PN}-demoapps"
index 9263828a1a3f92e89629c13ca07919d7f0d4d0d6..6ef844fc7caf808693a52b3e2685f315c5beb5ff 100644 (file)
@@ -2,6 +2,9 @@ SUMMARY = "Qt for Embedded Linux (Qt without X11)"
 PR = "r2"
 LICENSE = "MIT"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 # For backwards compatibility after rename
index 8413eecaa15dd437634bd307bebbdcc023961408..fc1ccba9a74a72c08ac16f3528e50d544331f48e 100644 (file)
@@ -1,5 +1,8 @@
 LICENSE = "MIT"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"