]> code.ossystems Code Review - openembedded-core.git/commitdiff
libaio: extend to nativesdk
authorChen Qi <Qi.Chen@windriver.com>
Tue, 23 Oct 2018 04:58:22 +0000 (12:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 25 Oct 2018 13:36:34 +0000 (14:36 +0100)
lvm2 currently requires libaio. So building nativesdk-lvm2 will
result in the following error.

  ERROR: Required build target 'nativesdk-lvm2' has no buildable providers.
  Missing or unbuildable dependency chain was: ['nativesdk-lvm2', 'nativesdk-libaio']

Extend libaio to nativesdk to fix this issue.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/libaio/libaio_0.3.111.bb

index 5bd83078acc104aa41905ea82d1d1790df600594..04b50b61ecde18761011cd339f9d466d7c463047 100644 (file)
@@ -19,3 +19,5 @@ EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
 do_install () {
     oe_runmake install DESTDIR=${D}
 }
+
+BBCLASSEXTEND = "nativesdk"