]> code.ossystems Code Review - openembedded-core.git/commitdiff
environment files: Added and unified version related variables.
authorLianhao Lu <lianhao.lu@intel.com>
Mon, 1 Aug 2011 07:50:02 +0000 (15:50 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Aug 2011 14:01:17 +0000 (15:01 +0100)
[YOCTO #1306] Fixing.

Added and unified version related variables in all environment files
generated by package meta-toolchain, meta-ide-support,
meta-environment-xxx.

Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
meta/classes/toolchain-scripts.bbclass
meta/recipes-core/meta/meta-environment.bb
meta/recipes-core/meta/meta-ide-support.bb
meta/recipes-core/meta/meta-toolchain.bb

index 832cce41a9d558c01a5ba8bd1be982eacb3d3df2..fe11e7278ee81b32df7e0997c0acf77eb0b0dd05 100644 (file)
@@ -30,6 +30,7 @@ toolchain_create_sdk_env_script () {
        echo 'export OECORE_TARGET_SYSROOT="${SDKTARGETSYSROOT}"' >> $script
        echo 'export OECORE_ACLOCAL_OPTS="-I ${SDKPATHNATIVE}/usr/share/aclocal"' >> $script
        echo 'export POKY_DISTRO_VERSION="${DISTRO_VERSION}"' >> $script
+       echo 'export POKY_SDK_VERSION="${SDK_VERSION}"' >> $script
 }
 
 # This function creates an environment-setup-script in the TMPDIR which enables
@@ -61,6 +62,8 @@ toolchain_create_tree_env_script () {
        echo 'export OECORE_NATIVE_SYSROOT="${STAGING_DIR_NATIVE}"' >> $script
        echo 'export OECORE_TARGET_SYSROOT="${STAGING_DIR_TARGET}"' >> $script
        echo 'export OECORE_ACLOCAL_OPTS="-I ${STAGING_DIR_NATIVE}/usr/share/aclocal"' >> $script
+       echo 'export POKY_DISTRO_VERSION="${DISTRO_VERSION}"' >> $script
+       echo 'export POKY_SDK_VERSION="${SDK_VERSION}"' >> $script
 }
 
 # This function creates an environment-setup-script for use by the ADT installer
index 6d547bba203fdd71b2004b61c88711f69558eebb..114727cf3c463e9590168ecc4df196c457e36a95 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Package of environment files for SDK"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 LICENSE = "MIT"
-PR = "r5"
+PR = "r6"
 
 EXCLUDE_FROM_WORLD = "1"
 
index 7a3c053a07cf9532b851aee08ab7c3c68a1f66d2..326b25a09c63253b167d64d3c6657775eaea2fbd 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 DEPENDS = "virtual/libc gdb-cross qemu-helper-native unfs-server-native"
-PR = "r1"
+PR = "r2"
 
 inherit meta toolchain-scripts
 
index ab98bf99b2c24b63b605affe4af6728d2165414b..164d7177f58a16bd293e93048a624acec023d9c8 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Meta package for building a installable toolchain"
 LICENSE = "MIT"
 
-PR = "r4"
+PR = "r5"
 
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"