]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: supporting on Linux kernel 3.x
authorLin Tong <tong.lin@intel.com>
Thu, 11 Aug 2011 06:01:52 +0000 (14:01 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 15 Aug 2011 14:13:33 +0000 (15:13 +0100)
The old valgrind package do not support for Linux kernel 3.x, only for
kernel 2.4 and 2.6. Now adding the configuration to the configure.in
file to support Linux kernel 3.0.

This commit fixes the problem in valgrind [YOCTO #1129]

Signed-off-by: Lin Tong <tong.lin@intel.com>
meta/recipes-devtools/valgrind/valgrind-3.6.1/fix_unsupporting_kernel_3.patch [new file with mode: 0644]
meta/recipes-devtools/valgrind/valgrind_3.6.1.bb

diff --git a/meta/recipes-devtools/valgrind/valgrind-3.6.1/fix_unsupporting_kernel_3.patch b/meta/recipes-devtools/valgrind/valgrind-3.6.1/fix_unsupporting_kernel_3.patch
new file mode 100644 (file)
index 0000000..346ffeb
--- /dev/null
@@ -0,0 +1,26 @@
+valgrind: Add 3.x statements to "case" for supporting the kernel 3.x
+
+Signed-off-by: Lin Tong <tong.lin@intel.com>
+
+Upstream-Status: Pending
+
+diff --git a/configure.in b/configure.in
+index 3878619..1cb7dc7 100644
+--- a/configure.in
++++ b/configure.in
+@@ -229,10 +229,14 @@ case "${host_os}" in
+                   AC_MSG_RESULT([2.4 family (${kernel})])
+                   AC_DEFINE([KERNEL_2_4], 1, [Define to 1 if you're using Linux 2.4.x])
+                   ;;
++             3.*)
++                    AC_MSG_RESULT([3 family (${kernel})])
++                    AC_DEFINE([KERNEL_3], 1, [Define to 1 if you're using Linux 3.x])
++                    ;;
+              *) 
+                   AC_MSG_RESULT([unsupported (${kernel})])
+-                  AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
++                  AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6, 3.x])
+                   ;;
+         esac
index d5dcdd6ebe7462e6f79aef8232d0db3fd580c57a..021caa8a6e1257dda9370a8422f252fed1268ee5 100644 (file)
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
                     file://include/valgrind.h;beginline=1;endline=56;md5=13a71cedba99112334d8596162aec37e \
                     file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
 DEPENDS = "virtual/libx11"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
           file://fix_issue_caused_by_ccache.patch \
+           file://fix_unsupporting_kernel_3.patch \
            file://fixed-perl-path.patch"
 
 SRC_URI[md5sum] = "2c3aa122498baecc9d69194057ca88f5"