]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: enable gallium intel drivers when building for x86
authorAlexander Kanavin <alex.kanavin@gmail.com>
Sat, 19 Jun 2021 09:58:45 +0000 (11:58 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jun 2021 10:09:34 +0000 (11:09 +0100)
Iris is the default, recommended option for Skylake and newer nowadays,
i915 gallium is favoured over classic i915, and soon classic i965 will
be replaced by crocus gallium driver for i965-to-Haswell GPUs.

(From OE-Core rev: 670878b5919c2a67a2fea0b8e1f032e324fad5aa)

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
meta/recipes-graphics/mesa/mesa.inc
meta/recipes-graphics/mesa/mesa_21.1.2.bb

index 5700cc9673af02dec1d855690811ff154eeb778a..b3c8c292ff77f44ed68dc938772eeff8cdcf38f5 100644 (file)
@@ -131,6 +131,9 @@ PACKAGECONFIG[v3d] = ""
 GALLIUMDRIVERS = "swrast"
 # gallium swrast was found to crash Xorg on startup in x32 qemu
 GALLIUMDRIVERS_x86-x32 = ""
+# Add crocus when 21.2 is out to the list below to support the full range of Intel GPUs
+GALLIUMDRIVERS_append_x86_class-target = ",i915,iris"
+GALLIUMDRIVERS_append_x86-64_class-target = ",i915,iris"
 
 GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'etnaviv', ',etnaviv', '', d)}"
 GALLIUMDRIVERS_append ="${@bb.utils.contains('PACKAGECONFIG', 'freedreno', ',freedreno', '', d)}"
index 1993d6cbd0f5226f59a7e9192baec0ba3a3c541b..28abc91a87b0897b7e5cc2691cffca3dafca443b 100644 (file)
@@ -1,5 +1,5 @@
 require ${BPN}.inc
 
-DRIDRIVERS_append_x86_class-target = ",r100,r200,nouveau,i965,i915"
-DRIDRIVERS_append_x86-64_class-target = ",r100,r200,nouveau,i965,i915"
+DRIDRIVERS_append_x86_class-target = ",r100,r200,nouveau,i965"
+DRIDRIVERS_append_x86-64_class-target = ",r100,r200,nouveau,i965"