]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxosd: added version from OE + fixed packaging
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 9 Jul 2007 13:24:31 +0000 (13:24 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 9 Jul 2007 13:24:31 +0000 (13:24 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2131 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/libxosd/files/autofoo.patch [new file with mode: 0644]
meta-extras/packages/libxosd/files/use-sane-default-font.patch [new file with mode: 0644]
meta-extras/packages/libxosd/libxosd_svn.bb [new file with mode: 0644]

diff --git a/meta-extras/packages/libxosd/files/autofoo.patch b/meta-extras/packages/libxosd/files/autofoo.patch
new file mode 100644 (file)
index 0000000..e26f15e
--- /dev/null
@@ -0,0 +1,116 @@
+Index: current/configure.ac
+===================================================================
+--- current.orig/configure.ac  2007-06-14 09:06:04.000000000 +0000
++++ current/configure.ac       2007-06-14 09:14:37.000000000 +0000
+@@ -52,8 +52,6 @@
+ CFLAGS="$CFLAGS $X_CFLAGS -Wall"
+ dnl Checks for libraries.
+-AM_PATH_GTK(1.2.2,,
+-          AC_MSG_WARN([*** GTK+ >= 1.2.2 not found ***]))
+ AC_CHECK_LIB(X11, XInitThreads,,
+            AC_MSG_ERROR([*** X11 not threadsafe ***]))
+ AC_CHECK_LIB(Xext, XShapeQueryExtension,,
+@@ -107,63 +105,6 @@
+       AC_MSG_WARN("beep media player not found")
+ fi
+-dnl Check for xmms
+-AM_PATH_XMMS(1.2.7,,
+-           AC_MSG_WARN("xmms plugins can not be built"))
+-dnl Override where to place libxmms_xosd.so
+-AC_ARG_WITH([plugindir],
+-            AC_HELP_STRING([--with-plugindir=DIR],
+-                         [Set the xmms plugin directory]),
+-            [XMMS_PLUGIN_DIR="$withval"],
+-            [XMMS_PLUGIN_DIR="$XMMS_GENERAL_PLUGIN_DIR"])
+-
+-dnl Check for gdk-pixbuf
+-AM_PATH_GDK_PIXBUF(0.22.0,,
+-                 AC_MSG_WARN("new xmms plugin can not be built"))
+-dnl Override where to place pixmaps for libxmms_xosd.so
+-AC_ARG_WITH([pixmapdir],
+-          AC_HELP_STRING([--with-pixmapdir=DIR],
+-                         [Set the directory for xmms plugin pixmaps]),
+-            [XMMS_PIXMAPDIR="$withval"],
+-            [XMMS_PIXMAPDIR="${datadir}/xosd"])
+-AC_SUBST(XMMS_PIXMAPDIR)
+-
+-dnl NEW plugin
+-AC_ARG_ENABLE([new-plugin],
+-            AC_HELP_STRING([--disable-new-plugin],
+-                           [Disable new xmms plugin (enabled by default)]),
+-              [enable_new_plugin="$enableval"],
+-            [enable_new_plugin="yes"])
+-AC_MSG_CHECKING([whether new xmms plugin was requested])
+-AC_MSG_RESULT($enable_new_plugin)
+-AM_CONDITIONAL([BUILD_NEW_PLUGIN],
+-             [test x"$enable_new_plugin" = "xyes" -a x"$no_xmms" != "xyes" -a x"$no_gdk_pixbuf" != "xyes"])
+-
+-
+-dnl Check for Beep Media player
+-AC_ARG_ENABLE([beep_media_player_plugin],
+-              AC_HELP_STRING([--enable-beep_media_player_plugin],
+-                           [Enable beep media plugin (enabled by default)]),
+-              [beep_media_player_plugin="$enableval"],
+-              [beep_media_player_plugin="yes"])
+-AC_MSG_CHECKING([whether beep media plugin was requested])
+-AC_MSG_RESULT($beep_media_player_plugin)
+-
+-AM_CONDITIONAL([BUILD_BEEP_MEDIA_PLUGIN],
+-             [test x"$beep_media_player_plugin" = "xyes" -a x"$no_bmp" == "xyes"])
+-
+-dnl OLD plugin
+-AC_ARG_ENABLE([old-plugin],
+-            AC_HELP_STRING([--enable-old-plugin],
+-                           [Enable old xmms plugin (disabled by default)]),
+-              [enable_old_plugin="$enableval"],
+-              [enable_old_plugin="no"])
+-AC_MSG_CHECKING([whether old xmms plugin was requested])
+-AC_MSG_RESULT($enable_old_plugin)
+-AM_CONDITIONAL([BUILD_OLD_PLUGIN],
+-             [test x"$enable_old_plugin" = "xyes" -a x"$no_xmms" != "xyes"])
+-
+-
+ dnl Define XOSD_VERSION
+ AC_DEFINE_UNQUOTED(XOSD_VERSION, "${VERSION}")
+@@ -174,8 +115,6 @@
+ Makefile
+ src/Makefile
+ src/libxosd/Makefile
+-src/xmms_plugin/Makefile
+-src/bmp_plugin/Makefile
+ macros/Makefile
+ man/Makefile
+ pixmaps/Makefile
+Index: current/src/Makefile.am
+===================================================================
+--- current.orig/src/Makefile.am       2007-06-14 09:06:04.000000000 +0000
++++ current/src/Makefile.am    2007-06-14 09:14:37.000000000 +0000
+@@ -10,6 +10,4 @@
+ include_HEADERS = xosd.h
+-AM_CFLAGS = ${GTK_CFLAGS}
+-
+-SUBDIRS=libxosd xmms_plugin bmp_plugin
++SUBDIRS=libxosd
+Index: current/Makefile.am
+===================================================================
+--- current.orig/Makefile.am   2007-06-14 09:06:04.000000000 +0000
++++ current/Makefile.am        2007-06-14 09:16:15.000000000 +0000
+@@ -1,11 +1,5 @@
+-if BUILD_NEW_PLUGIN
+-      NEW_SUB = pixmaps
+-endif
+-if BUILD_BEEP_MEDIA_PLUGIN
+-      NEW_SUB = pixmaps
+-endif
+-SUBDIRS = macros man $(NEW_SUB) src script
+-DIST_SUBDIRS = macros man pixmaps src script
++SUBDIRS = macros man src script
++DIST_SUBDIRS = macros man src script
+ DISTCLEANFILES = libtool-disable-static
diff --git a/meta-extras/packages/libxosd/files/use-sane-default-font.patch b/meta-extras/packages/libxosd/files/use-sane-default-font.patch
new file mode 100644 (file)
index 0000000..0ede135
--- /dev/null
@@ -0,0 +1,13 @@
+Index: current/src/libxosd/xosd.c
+===================================================================
+--- current.orig/src/libxosd/xosd.c    2007-06-16 19:37:48.000000000 +0000
++++ current/src/libxosd/xosd.c 2007-06-17 05:00:47.000000000 +0000
+@@ -26,7 +26,7 @@
+ #define XOFFSET 10
+ const char * const osd_default_font =
+-  "-misc-fixed-medium-r-semicondensed--*-*-*-*-c-*-*-*";
++  "fixed";
+ #if 0
+ "-adobe-helvetica-bold-r-*-*-10-*";
+ #endif
diff --git a/meta-extras/packages/libxosd/libxosd_svn.bb b/meta-extras/packages/libxosd/libxosd_svn.bb
new file mode 100644 (file)
index 0000000..7dfd05d
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "A library for displaying a TV-like on-screen display in X."
+SECTION = "libs/x11"
+DEPENDS = "virtual/libx11 libxext"
+LICENSE = "LGPL"
+PV = "2.2.15+svn${SRCDATE}"
+PR = "r5"
+
+SRC_URI = "svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https \
+           file://autofoo.patch;patch=1 \
+           file://use-sane-default-font.patch;patch=1"
+
+S = "${WORKDIR}/current"
+
+inherit autotools binconfig
+
+do_stage() {
+       autotools_stage_all
+}
+
+PACKAGES =+ "${PN}-examples-dbg ${PN}-examples"
+FILES_${PN}-examples = "${bindir}/osd_cat"
+FILES_${PN}-examples-dbg = "${bindir}/.debug/"
+FILES_${PN}-dev += "${bindir}/xosd-config"
+FILES_${PN} = "${libdir}/libxosd.so.*"